Ask Your Question

Fedora 19 64bit Install DVD doesn't boot via UEFI on Panasonic CF-LX3

asked 2013-11-03 23:41:48 -0500

Linux Freak gravatar image

updated 2014-09-30 23:11:24 -0500

mether gravatar image


I have a new Panasonic CF-LX3 laptop with Windows 8 pre-installed. I was able to use the included disk tool to shrink the Windows partition, give me 145 Gb of space for a Fedora install.

I downloaded the 64bit Fedora 19 full install DVD. I am not able to boot it in UEFI mode, however. It consistently fails with a blue screen saying:

Secure Boot Violation Invalid signature detected.
Check Secure Boot state in Setup.

I have found no way around this issue using UEFI enabled. I tried booting with UEFI disabled (ie. standard BIOS boot) and was able to install Fedora without difficulty. However, as expected, I found my Windows partition no longer bootable. I ended up re-enabling UEFI, wiping my entire system, and restoring Windows from the recovery DVDs.

Is there anything I can do to get the Fedora DVD to boot and get a dual-boot Windows 8 / Fedora 19 system working with UEFI? I am not enjoying my Windows 8 "experience" even one little bit, but I do have significant Windows dependencies so am not able to move to 100% Fedora (as much as I would love to).

edit retag flag offensive close merge delete


I also created a Live Fedora 19 bootable USB. Same error.

Linux Freak gravatar imageLinux Freak ( 2013-11-04 18:35:07 -0500 )edit

No ideas, I take it? Is this likely something with my laptop's firmware that I would not be able to work around without a firmware upgrade? Or, is this something Fedora 20's installer will be likely to offer a fix for?

Linux Freak gravatar imageLinux Freak ( 2013-11-17 06:31:37 -0500 )edit

This is the first time since 1995 I seem to have managed to stump everyone in the Linux community on a question. ;-) + ;-(

Linux Freak gravatar imageLinux Freak ( 2013-11-25 07:09:33 -0500 )edit

I've got a simmilar problem on my laptop as well, but in my case, instead of disabling the UEFI, I have the option to switch to Legacy Support boot. Is it any different?

Quantum Helix gravatar imageQuantum Helix ( 2014-09-17 23:41:14 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-11-27 09:58:49 -0500

Linux Freak gravatar image

Well, UEFI is definitely enabled, but problem is if I disable for Fedora, I can no longer boot Windows and vice-versa. I believe somehow I need to get Fedora booting somehow in UEFI mode, then proceed with normal install, that would allow me to easily dual-boot between them.

Question is, though, "how". :(

edit flag offensive delete link more

answered 2013-11-26 05:33:42 -0500

pawlx0r gravatar image

Secure Boot Violation Invalid signature detected. Check Secure Boot state in Setup.

From everything I have read, and I am a newbie to this -- that message means that Secure Boot (different from UEFI) is enabled. You should be able to disable that in your UEFI (BIOS) while leaving UEFI Mode enabled so that Windows 8 will still boot.

I've been going crazy trying to get an EFI mode Linux installed on my Windows 8 laptop as a dual boot, so I have been reading and learning a lot. I was going to give Fedora 19 a try as it is supposed to be EFI-a-okay, but I recognized that error from other forums. Hope it helps.

edit flag offensive delete link more


It sounds like a locked secure boot system to me, too. You can disable SecureBoot, or you can put the system into "maintenance mode" or "installation mode" or whatever your vendor calls it. The procedure is specific to a given piece of hardware, of course.

randomuser gravatar imagerandomuser ( 2013-11-26 21:18:39 -0500 )edit

That turned out to be the correct approach. Previously, i was disabling UEFI itself, but what I needed to actually do is disable Secure Boot. I now have Fedora 20 dual-booting with Windows 8.1 Only a couple of things bother me:

  • Need to somehow add the Fedora UEFI key to my firmware so I can re-enable Secure Boot
  • Need to figure out why, sometimes, restarting from Linux ends up resetting the UEFI boot priority and finding myself loading the Restore Windows UEFI at next boot. (Highly annoying, but can easily re-enter BIOS and change back.)
Linux Freak gravatar imageLinux Freak ( 2014-01-05 08:36:20 -0500 )edit

Question Tools

1 follower


Asked: 2013-11-03 23:41:48 -0500

Seen: 1,555 times

Last updated: Nov 27 '13