Ask Your Question
0

switchdesktop fedora 19

asked 2013-11-03 22:07:49 -0500

jennifer gravatar image

updated 2014-05-11 13:51:27 -0500

mether gravatar image

I am on a 64 bit machine running fedoroa 19 with Gnome shell 3.8.4. I downloaded switchdesk along with xfce and I see the choice to switch but than I get the error :"Your desktop configuration has successfully been updated,but you must restart the X Window System for the changes to take effect." Which is apparently not the same as restarting the system because I have done that several times. When I log out I only get the option to log back into gnome. Help please. I don't know the terminal code for restarting X Window System. I thought maybe I don't even have X window system and when I try to install it yum groupinstall "X Window System" I get a not there error. I want to be able to switch desktops.

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2013-11-06 09:23:25 -0500

anishjp gravatar image

updated 2013-11-06 09:25:43 -0500

I haven't used switchdesk but I have used another manager to switch between different displays and it has worked fine. If you want you can give it a try

yum install system-switch-displaymanager

Logout and you should see an option to choose your second display!

edit flag offensive delete link more
0

answered 2013-11-03 22:49:26 -0500

Ahmad Samir gravatar image

Logging out restarts the X server.

To be sure that you have installed XFCE properly, run:

yum groups install "XFCE Desktop"

(if you haven't done so already).

edit flag offensive delete link more
0

answered 2014-01-16 11:10:28 -0500

SuperGreg gravatar image

updated 2014-01-16 12:50:38 -0500

OK, I had the same issue (Fedora 20). Installed KDE and Xfce, and switchdesktop has no effect whatsoever. I also didn't see the option to choose a desktop when logging in.

I just figured it out, you have to select your user first, then you will get an icon appear (looks like a gear) that will allow you to choose your desktop. I had never noticed this before, and searched the entire screen before selecting the user so I didn't find it.

Hope this helps.

edit flag offensive delete link more
0

answered 2013-11-05 13:33:12 -0500

jennifer gravatar image

I fixed this problem by creating a password and another user and only then did I see the drop down menu option to chose a session when entering the login window.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-11-03 22:07:49 -0500

Seen: 2,506 times

Last updated: Jan 16 '14