Ask Your Question
0

Totem not playing videos after adding gstreamer

asked 2013-11-02 01:34:18 -0500

J903 gravatar image

updated 2014-04-11 16:21:23 -0500

remjg gravatar image

I've added the rpm free and non free repos (forgive me if that's not what they're called. I'm coming over from Ubuntu which I feel has gotten to corporately focused.) This isn't my first experience with other distros but yum is a new one for me. After adding the RPMs I started to play an FLV in totem. The video played fine. After a reboot last night, totem doesn't want to play FLVs any longer. All help is appreciated. Thanks.

EDIT: I am also using Fedora 19.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-11-02 08:58:23 -0500

Marc lml gravatar image

You could try to install the codecs from Fedora Utils.

Install Fedora Utils and the codecs.

su -c "curl http://download.opensuse.org/repositories/home:/satya164:/fedorautils/Fedora_19/home:satya164:fedorautils.repo -o /etc/yum.repos.d/fedorautils.repo && yum install fedorautils"

fedorautils --exec install_codecs

With fedorautils --exec list you can see all available commands.

Instead of using the command line, you can also use the GUI.

edit flag offensive delete link more

Comments

This should not be necessary and may lead to conflicts. Type sudo yum install gstreamer* to install all of the good, bad, & ugly (patent-encumbered codecs) gstreamer plugins. Then type "gst-launch-1.0 playbin uri=file:///home/joe/my-random-media-file.flv" This way you will know if you have all the gstreamer plugins installed. If it plays, then totem should automatically use the gstreamer backend with all the plugins. (Totem may then need reinstalling. "sudo yum reinstall totem". Anton.

aws gravatar imageaws ( 2013-12-16 04:50:32 -0500 )edit

Question Tools

Stats

Asked: 2013-11-02 01:34:18 -0500

Seen: 1,391 times

Last updated: Nov 02 '13