Ask Your Question
0

F18 packages and repo on F19?

asked 2013-10-29 13:50:15 -0500

petkaux gravatar image

updated 2014-04-11 16:08:31 -0500

remjg gravatar image

Hi, I have recently upgraded my F18 to F19 using fedup. /etc/redhat-release confirms that now I am on Schrodinger's Cat. When I do

yum list installed

it says most of my packages are f18.

example:

zeitgeist.x86_64 0.9.5-1.fc18 installed
zeitgeist-datahub.x86_64 0.9.5-1.fc18 installed
zenity.x86_64 3.6.0-1.fc18 @fedora
zip.x86_64 3.0-5.fc18 installed
zisofs-tools.x86_64 1.0.8-8.fc18 installed
zlib.x86_64 1.2.7-10.fc19 installed

Is this normal? And why does

yum repolist

say that my repositories are f18?

updates/18/x86_64 Fedora 18 - x86_64 - Updates
fedora/18/x86_64 Fedora 18 - x86_64

Please shed some lights. Thanks

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-10-29 16:16:36 -0500

Felix Schwarz gravatar image

Something like this can happen if the upgrade path is broken in Fedora which means that an older distro (e.g. F18) has a higher package version than the newer distro (F19). However these cases should be rare.

To me it looks like that your upgrade process was not successful. As you mentioned yum repolist already I'd first check /etc/yum.repos.d for explicit F18 references (you should see $releasever in the urls there).

Assuming your repo files are good you could try to replace the $releasever with an explicit reference to "19" and do yum update. You should see a lot of package updates then though I have to warn you: Basically the update will do a yum-based upgrade and part of your system seems to be updated already. In your case I recommend a solid backup before proceeding because you might experience a lot of nasty stuff (up to possible data loss!).

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-10-29 13:50:15 -0500

Seen: 128 times

Last updated: Oct 29 '13