Ask Your Question
0

Overheating problem

asked 2013-10-27 11:16:48 -0500

Andrea Cacioppo gravatar image

updated 2014-05-11 14:01:24 -0500

mether gravatar image

Hi everyone! I've just installed fedora 19 on my acer aspire v3-771g with the desktop environment GNOME and i have 1 problemM: My pc overheats quickly also without using applications (it's a new pc and it doesn't heat with other systems), anyone knows how to solve it?

edit retag flag offensive close merge delete

Comments

OK, i've installed bumblebee but i've problems with the configuration, i open /etc directory, than bumblebee an than bumblebee.conf, i modify the strigs how is told to do in the page https://github.com/Bumblebee-Project/Bumblebee/wiki/Configuration but i can't save the file modified because it's a "only read file", what i'm doing wrong? ... about the brightness the GNOME extension doesn't work, i can move the cursor but the brightness doesnt't change :/

Andrea Cacioppo gravatar imageAndrea Cacioppo ( 2013-10-27 12:46:17 -0500 )edit

You have to open the file as an administrator to be able to modify it. Open a terminal, type su <enter> your root password <enter> to connect as an administrator. Then to open the configuration file type : gedit /etc/bumblebee/bumblebee.conf

remjg gravatar imageremjg ( 2013-10-27 12:49:55 -0500 )edit

ok i did it and i rebooted but i can't see changes, te fan continues to spin at maximum

Andrea Cacioppo gravatar imageAndrea Cacioppo ( 2013-10-27 13:10:50 -0500 )edit

if i give "optirun glxgears -info" this is the answer:[ 241.540249] [ERROR]The Bumblebee daemon has not been started yet or the socket path /var/run/bumblebee.socket was incorrect. [ 241.540310] [ERROR]Could not connect to bumblebee daemon - is it running?

Andrea Cacioppo gravatar imageAndrea Cacioppo ( 2013-10-27 13:12:34 -0500 )edit

To check if the card is successfully disabled, type the command cat /proc/acpi/bbswitch. The result shoulf be ... OFF. It seems like in your case, the bumblebee deamon is not started yet.

remjg gravatar imageremjg ( 2013-10-27 13:39:47 -0500 )edit

The result is: ON. the card is not disabled

Andrea Cacioppo gravatar imageAndrea Cacioppo ( 2013-10-27 15:15:33 -0500 )edit

Could you type the command dmesg | grep bbswitch and tell me what you get. Also, which nVidia driver are you using: the open source driver Nouveau or the proprietary driver nVidia?

remjg gravatar imageremjg ( 2013-10-27 15:53:03 -0500 )edit

the output is:[ 91.721240] bbswitch: version 0.7 [ 91.721246] bbswitch: Found integrated VGA device 0000:00:02.0: _SB_.PCI0.GFX0 [ 91.721249] bbswitch: Found discrete VGA device 0000:01:00.0: _SB_.PCI0.PEG0.PEGP [ 91.721313] bbswitch: detected an Optimus _DSM function [ 91.721320] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is on [ 142.230306] bbswitch: disabling discrete graphics

Andrea Cacioppo gravatar imageAndrea Cacioppo ( 2013-10-27 16:08:46 -0500 )edit

i really don't know wich drivers i have

Andrea Cacioppo gravatar imageAndrea Cacioppo ( 2013-10-27 16:11:03 -0500 )edit

This looks good. When you edited the file bumblebee.conf, did you write Driver=nouveau or Driver=nvidia under the [bumblebeed] section?

remjg gravatar imageremjg ( 2013-10-27 16:22:22 -0500 )edit

Driver=nvidia

Andrea Cacioppo gravatar imageAndrea Cacioppo ( 2013-10-27 16:26:21 -0500 )edit

Okay. On my system, I use Nouveau since I don't care about using the discrete GPU (warms too much). Did you enable the RPMfusion Free and Non free repository?

remjg gravatar imageremjg ( 2013-10-27 17:03:27 -0500 )edit

Forget what I wrote about the RPMfusion repository. Can you execute this command so I can check if you installed everything : rpm -qa | grep bumblebee

remjg gravatar imageremjg ( 2013-10-27 17:11:09 -0500 )edit

bumblebee-nonfree-release-1.1-1.noarch bumblebee-release-1.1-1.noarch bumblebee-nvidia-319.49-1.fc19.i686 bumblebee-3.2.1-4.fc19.i686

Andrea Cacioppo gravatar imageAndrea Cacioppo ( 2013-10-27 18:39:02 -0500 )edit

Well, I don't know what is wrong, maybe the nVidia kernel module can't be compiled. In this case, you might install the following packages : kernel-headers, glibc-devel. Then restart, and if it's not working, type systemctl | grep bumblebee as an administrator and copy here the result.

remjg gravatar imageremjg ( 2013-10-28 03:52:28 -0500 )edit

both the packages were already installed, here's the output: bumblebee-nvidia.service loaded active exited Compiling NVidia Driver bumblebeed.service loaded active running Bumblebee C Daemon

Andrea Cacioppo gravatar imageAndrea Cacioppo ( 2013-10-28 05:25:27 -0500 )edit

When searching on the internet, you could also try to blacklist Nouveau, check if your user belongs to the bumblebee group in /etc/group, but honestly I don't know. If you really need the additional nvidia GPU, you could try on another forum where more people are reading. Or you can give up and try using Bumblebee with Nouveau as I do (my card is deactivated and It didn't require extra work).

remjg gravatar imageremjg ( 2013-10-28 06:00:51 -0500 )edit

Blacklisting nouveau might be the solution (my idea is that nouveau is loaded and therefore the nvidia module can't be loaded too and the card can't be deactivated). Look at this blog post. If I sum up, you have to type as root gedit /etc/modprobe.d/blacklist.conf, you add the line blacklist nouveau and you save.

remjg gravatar imageremjg ( 2013-10-28 06:13:09 -0500 )edit

OK, it's solved, i just installed fedora again but now with the graphic environment xfce (I don't know if this made the difference but who cares) and installed bumblebee again, now it's working :)

Andrea Cacioppo gravatar imageAndrea Cacioppo ( 2013-10-29 17:26:51 -0500 )edit

1 Answer

Sort by » oldest newest most voted
2

answered 2013-10-27 11:37:07 -0500

remjg gravatar image

updated 2013-10-27 12:55:31 -0500

1) Overheating issue

Your laptop seems to have two GPU (optimus technology) :

You need to use Bumblebee to desactivate the second GPU. To do so, follow the steps below :

2) Lack of brightness control

You can use a GNOME Shell extension to control the screen brightness when the keyboard shortcuts don't work : Brigtness Control.

If it doesn't work for you, maybe this blog post will help you a little bit. You can change the brightness in the BIOS when starting the computer (which is a work around not very convenient) or there are other methods that involve command lines (see the comments).

Let me know if you have issue installing and configuring Bumblebee.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-10-27 11:16:48 -0500

Seen: 335 times

Last updated: Oct 31 '13