Ask Your Question
1

Nautilus can't browse the windows network ("Unable to access location") [closed]

asked 2013-10-26 12:51:14 -0500

remjg gravatar image

updated 2013-10-27 10:25:57 -0500

I used to access Windows shares using Nautilus on Fedora 19 but there seems to be something missing on my new Fedora 20 installation.

Here is what I get when I select Browse Network on the left panel of Nautilus and then click on Windows Network:

Unable to access location

Failed to retrieve share list from server: No such file or directory

You can check the list of packages below that are already installed:

$ rpm -qa | grep -e "smb" -e "samba"
fuse-smb-0.8.7-11.fc18.x86_64
samba-client-4.1.0-2.fc20.x86_64
samba-winbind-clients-4.1.0-2.fc20.x86_64
samba-libs-4.1.0-2.fc20.x86_64
libsmbclient-4.1.0-2.fc20.x86_64
samba-common-4.1.0-2.fc20.x86_64
gvfs-smb-1.18.2-1.fc20.x86_64
gnome-vfs2-smb-2.24.4-14.fc20.x86_64
samba-winbind-modules-4.1.0-2.fc20.x86_64
samba-winbind-4.1.0-2.fc20.x86_64

Did I forget to install something? Should I change something in the firewall configuration?

Edit : the server is the box of my internet provider

 $ smbclient -L 192.168.0.254
        Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.37]

        Sharename       Type      Comment
        ---------       ----      -------
        Disque dur      Disk      AutoShare of fbxhdiskd partition 2
        IPC$            IPC       IPC Service (Freebox Server)
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.0.37]

        Server               Comment
        ---------            -------
        FREEBOX              Freebox Server

        Workgroup            Master
        ---------            -------
        WORKGROUP            FREEBOX

Edit 2 : I have been booting on a Fedora 19 live usb where browsing windows share is still working.

Checking the packages installed, it seems that I didn't forget anything :

[liveuser@localhost samba]$ rpm -qa | grep -e "smb" -e "samba"
libsmbclient-4.0.6-3.fc19.x86_64
samba-libs-4.0.6-3.fc19.x86_64
samba-common-4.0.6-3.fc19.x86_64
gvfs-smb-1.16.3-1.fc19.x86_64
samba-client-4.0.6-3.fc19.x86_64

Furthermore, I didn't spot any difference in the configuration file /etc/samba/smb.conf.

edit retag flag offensive reopen merge delete

Closed for the following reason the question is answered, right answer was accepted by Akshay
close date 2013-12-24 10:41:57.468735

Comments

What does smbclient -L hostname_of_server show?

rickhg12hs gravatar imagerickhg12hs ( 2013-10-26 16:20:30 -0500 )edit

If you enter smb: in Nautilus' open location, what do you get?

rickhg12hs gravatar imagerickhg12hs ( 2013-10-26 16:46:16 -0500 )edit

Actually I get the same error.

remjg gravatar imageremjg ( 2013-10-26 16:52:22 -0500 )edit

Weird. What about entering smb://workgroup?

rickhg12hs gravatar imagerickhg12hs ( 2013-10-26 17:03:45 -0500 )edit

After reading some other posts, I'm wondering if the default auths changed or if your previous /etc/samba/smb.conf had some settings you need for the server. Perhaps adding client lanman auth = yes in the [global] section of /etc/samba/smb.conf might help, but I'm no expert on samba configuration (it's always "just worked"). Good luck!

rickhg12hs gravatar imagerickhg12hs ( 2013-10-26 17:18:52 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
0

answered 2013-10-27 10:29:14 -0500

remjg gravatar image

updated 2013-12-24 08:59:39 -0500

It seems that it is a firewall issue. Disabling the firewall brings back the ability to browse windows shares:

 sudo systemctl stop firewalld.service

I have tried opening the following ports using firewall-config (as suggested on another forum) without success:

Port      Protocole     
135       TCP and UDP
137       TCP and UDP
138       UDP        
139       TCP        
445       TCP and UDP

My wifi network is in the "home" zone of connection and I have also tried checking every services with no luck either...

So I have made a bug report in the meantime (bug 1023918).


Edit : the problem is solved with a recent update.

edit flag offensive delete link more
1

answered 2013-12-05 09:13:43 -0500

mildred gravatar image

Disabling firewall did not work for me, however, going to the direct URL of the samba share helped. I went to (Ctrl-L) smb://freebox-server.local/ and I could access my share.

It's the browsing that doesn't work.

edit flag offensive delete link more

Comments

Indeed, typing smb://freebox-server.local/ works for me. But I can confirm that disabling the firewall is a valid workaround.

remjg gravatar imageremjg ( 2013-12-06 01:27:09 -0500 )edit
0

answered 2013-12-05 08:10:39 -0500

dimitrti gravatar image

updated 2013-12-05 08:12:40 -0500

Indeed it has something to do with the firewall, samba seems to create some sort of vitrual net for the netbios, this is not in the 192.168.0.0/24 range but in 192.168.0.0/18 check your firewall if you accept outgoing connections from this range.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-10-26 12:51:14 -0500

Seen: 32,018 times

Last updated: Dec 24 '13