Ask Your Question
1

Fedora 19 no longer bootable

asked 2013-10-26 10:34:44 -0500

parisa gravatar image

updated 2014-04-11 15:48:40 -0500

remjg gravatar image

I had fedora dual-booted with windows on my laptop for a while but with windows refresh grub was gone and my system directly booted windows. I booted fedora with my systems boot options and with online tutorials I reinstalled grub2 but then had my system booted into an empty grub prompt: grub> So I found the drive containing vmlinuz and initramfs (completely sure about thair location and versions) and tried to manually boot it but after the boot command it said:

no suitable video mode found

booting in blind mode

and nothing happened.

Such a tragedy...

I have already tried to use live disks rescue system. Funny but troubleshooting options don't apear on my laptop while they do on my desktop pc. I cant even go to boot prompt on my lenovo idepad z400 laptop.

I also tried EasyBCD so maybe I could boot it with windows but it comes up with this error:

missing AutoNeoGrub().mbr

Now I have removed the grub prompt (don't know why) and its really hard for me to reinstall my dearly customized fedora. If anyone knows a way to help boot it again or reinstall it keeping my files and installations I really need it.

Thanks

PS:I have already tried Boot-repair Disk but it asks me to enable the repo containing grub-efi on my fedora to reinstall the grub2 and fix the boot for me (how could i?).

UPDATE: tnx marc van for your responses, my fdisk -l output:

WARNING: fdisk GPT support is currently new, and therefore in an experimental phase. Use at your own discretion.

Disk /dev/sda: 1000.2 GB, 1000204886016 bytes, 1953525168 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disk label type: gpt


#         Start          End    Size  Type            Name
 1         2048       616447    300M  Windows recover Basic data partition
 2       616448       821247    100M  EFI System      EFI system partition
 3       821248      1083391    128M  Microsoft reser Microsoft reserved partition
 4      1083392    978456575    466G  Microsoft basic Basic data partition
 5    978456576   1323304959  164.4G  Microsoft basic Basic data partition
 6   1323307008   1324331007    500M  Microsoft basic 
 7   1324331008   1953523711    300G  Linux LVM       

Disk /dev/mapper/live-rw: 8589 MB, 8589934592 bytes, 16777216 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes


Disk /dev/mapper/live-osimg-min: 8589 MB, 8589934592 bytes, 16777216 sectors
Units = sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes

UPDATE 2 my lvscan output: ACTIVE '/dev/fedora/swap' [5.77 GiB] inherit

ACTIVE            '/dev/fedora/home' [244.25 GiB] inherit

ACTIVE            '/dev/fedora/root' [50.00 GiB] inherit

UPDATE 3 tnx marc van for yor answer on update2 but first, it jast detected windows and second, still windows boot manager comes up

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-10-26 11:30:53 -0500

Marc lml gravatar image

updated 2013-10-30 13:19:17 -0500

Most likely Grub was not restored correctly. Please see my answer for question 34772 (this is a link) how to restore Grub with a default Fedora 19 installation.

Answer on UPDATE 2

Make a mount path to work with.

mkdir /mnt/root

Mount your LVM root partition to the mount path.

mount /dev/fedora/root /mnt/root

List /mnt/root. You should see your filesystem.

ls -la /mnt/root

List /mnt/root/boot. You should see your kernels

ls -la /mnt/root/boot

List /mnt/root/home. This should be empty, because it is not mounted yet.

ls -la /mnt/root/home

Mount your LVM home partition to the mount path. Please be aware that this step is not necessary for restoring Grub, but will provide you extra insight on how this works.

mount /dev/fedora/home /mnt/root/home

List /mnt/root/home. You should see your homefolders.

ls -la /mnt/root/home

If everything is ready, then you can restore Grub.

mount -o bind /dev /mnt/root/dev
mount -o bind /proc /mnt/root/proc
mount -o bind /sys /mnt/root/sys
mount -o bind /run /mnt/root/run
chroot /mnt/root
grub2-install --no-floppy --recheck /dev/sda
grub2-mkconfig -o /boot/grub2/grub.cfg
exit
/sbin/shutdown -r now
edit flag offensive delete link more

Comments

thnaks. Did all that and it recognized both windows and fedora but still no grub bootloader and only windows boot manager. I installed grub on dev/sda BTW

parisa gravatar imageparisa ( 2013-10-27 06:04:23 -0500 )edit

What is the output from fdisk -l from your machine?

Marc lml gravatar imageMarc lml ( 2013-10-27 13:03:13 -0500 )edit

It seems that fdisk -l does not show the information from your LVM volume. Can you post the output from lvscan?

P.S. I have closed https://ask.fedoraproject.org/question/34857/grub-dissapeared/.

Marc lml gravatar imageMarc lml ( 2013-10-28 16:11:11 -0500 )edit

Can you give a full output of all the commands to see what might be happening? There must be missing something. :)

Marc lml gravatar imageMarc lml ( 2013-10-31 13:36:25 -0500 )edit

Just had another idea. Have you tried inserting the Fedora Live DVD and disabling EFI prior to restoring Grub?

Marc lml gravatar imageMarc lml ( 2013-10-31 13:50:48 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2013-10-26 10:34:44 -0500

Seen: 1,410 times

Last updated: Oct 30 '13