Ask Your Question

How to disable PackageKit in Fedora 19 KDE?

asked 2013-10-25 00:29:21 -0600

hawkfeather gravatar image

updated 2014-03-18 17:10:10 -0600

mether gravatar image

PackageKit gets to be a real pest during installations and upgrades, by taking an inordinate amount of time to release the yum lock after each package finishes installing. So I was wondering how I could disable it before starting installations or upgrades? Thanx in advance.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-10-25 01:31:31 -0600

Bharat gravatar image

updated 2013-10-25 01:57:19 -0600

shaiton gravatar image

There is another post that answers your question: see #10929 That post talks about how to disable PackageKit by editing the preferences.

There is another brute force way: Kill packagekit : Find PID by ps ax|grep packagekit and then kill <PID>

edit flag offensive delete link more


Please avoid posting link as you did @Bharat. You can at least use plain text.. Also, force killing packagekit won't resolve the issue as it will start again later.

shaiton gravatar imageshaiton ( 2013-10-25 01:58:50 -0600 )edit

even if i codify the link address, I am not able to post it. I tried it. Yes I agree that killing wont solve the issue. As i said it is a temporary bruteforce solution: to allow yum upgrade at that instance.

Bharat gravatar imageBharat ( 2013-10-25 02:02:22 -0600 )edit

I don't think PackageKit is an indispensable part of a Fedora system. I've just uninstalled it as advised by #10929, then did an update, and everything worked out just fine. I believe that yumex and the command-line are all I'll need for package management. But if PackageKit is tying up your yum lock, you can halt it if you don't want to get rid of it altogether. [[ -f /var/run/ ]] && kill -15 $(cat /var/run/

hawkfeather gravatar imagehawkfeather ( 2013-10-28 00:39:01 -0600 )edit

Question Tools


Asked: 2013-10-25 00:29:21 -0600

Seen: 2,662 times

Last updated: Oct 25 '13