Ask Your Question
0

FC19 Update - WIFI Issue

asked 2013-10-24 12:27:55 -0500

gkraemer gravatar image

updated 2013-10-30 20:25:06 -0500

I'm a new FC19 user and loving it. I have installed FC19 on my Toshiba and managed to install the Realtek r8187se driver from rpmfusion. The rpm's were for the 3.11.4-201.fc19.x86_64 kernel were: kmod-staging-3.11.1-1.fc19.5.x86_64.rpm and kmod-staging-3.11.4-201.fc19.x86_64-3.11.1-1.fc19.5.x86_64.rpm rpmfusion-free-release-19.noarch.rpm I did not install all of the updates from rpmfusion, only the two kmod-staging* rpm's. Today, the kernel was updated to version 3.11.6-200.fc19.x86_64 and my WIFI no longer works. yum won't apply the older changes to the new kernel. rpmfusion doesn't have updates for the new kernel. My work around is to boot the 3.11.4-201.fc19.x86_64 kernel.

Is there a way to make the r8187se wifi driver work with the newer kernel update?

TIA

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-10-25 11:24:19 -0500

gkraemer gravatar image

updated 2013-10-30 20:21:31 -0500

Reference sites:

boot the latest kernel!

su -c "yum -y install yum-utils make gcc kernel-devel kernel-headers"

Use yumdownload to download your most recent installed kernel on you computer

$ yumdownloader --source kernel

downloaded: kernel-3.11.6-200.fc19.src.rpm

Use rpm2cpio[/c] and [i]cpio to extract rpm package

$ mkdir linux-3.11; cd linux-3.11

$ rpm2cpio ../kernel-3.11.6-200.fc19.src.rpm | cpio -idv

$ tar xf linux-3.11.tar.xz

Enter on staging folder and edit Makefile $ cd linux-3.3/drivers/staging/rtl8187se

As root, edit the Makefile:

$ vi Makefile

Add these lines to the end of file:

obj-m:= r8187se.o

KDIR := /lib/modules/$(shell uname -r)/build

PWD := $(shell pwd)

default: $(MAKE) -C $(KDIR) M=$(PWD) modules

$ TAB, not spaces are required before $(MAKE)in the line above!!!!!

Now we will compile module and put in our system:

$ make

$ mkdir /lib/modules/$(uname -r)/kernel/drivers/staging/rtl8187se

$ cp r8187se.ko /lib/modules/$(uname -r)/kernel/drivers/staging/rtl8187se/

$ /sbin/depmod -a

$ /sbin/modprobe r8187se

It now works!

However, a reboot or power up will cause it to be inoperative.

su password

$ cd /etc

$ echo modprobe r8187se >> /etc/rc.modules

$ chmod +x /etc/rc.modules

It should now work on every power up and reboot.

edit flag offensive delete link more
0

answered 2013-10-26 01:34:54 -0500

yanglifu90 gravatar image

You probably should install the metapackage kmod-staging.x86_64 instead of any other kernel specific ones. And what are you trying to do in the comments?

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-10-24 12:27:55 -0500

Seen: 660 times

Last updated: Oct 30 '13