Ask Your Question
2

Lid close action options missing

asked 2013-10-23 14:02:10 -0500

cclark gravatar image

updated 2014-08-19 01:31:23 -0500

abadrinath gravatar image

I have a Dell Latitude E6500 running Fedora 19, all up to date & there are no options for a lid close action available. I've installed gnome-tweak-tool & the options are missing from there as well. Here are the power settings I do have:

org.gnome.settings-daemon.plugins.power active true

org.gnome.settings-daemon.plugins.power button-hibernate 'hibernate'

org.gnome.settings-daemon.plugins.power button-power 'suspend'

org.gnome.settings-daemon.plugins.power button-sleep 'hibernate'

org.gnome.settings-daemon.plugins.power button-suspend 'suspend'

org.gnome.settings-daemon.plugins.power critical-battery-action 'hibernate'

org.gnome.settings-daemon.plugins.power idle-brightness 30

org.gnome.settings-daemon.plugins.power idle-dim false

org.gnome.settings-daemon.plugins.power notify-perhaps-recall true

org.gnome.settings-daemon.plugins.power percentage-action 2

org.gnome.settings-daemon.plugins.power percentage-critical 3

org.gnome.settings-daemon.plugins.power percentage-low 10

org.gnome.settings-daemon.plugins.power priority 0

org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 3600

org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'nothing'

org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 3600

org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type 'suspend'

org.gnome.settings-daemon.plugins.power time-action 120

org.gnome.settings-daemon.plugins.power time-critical 300

org.gnome.settings-daemon.plugins.power time-low 1200

org.gnome.settings-daemon.plugins.power use-time-for-policy true
edit retag flag offensive close merge delete

Comments

And what options are you looking for?

skytux gravatar imageskytux ( 2013-10-23 14:48:13 -0500 )edit

Well, usually there are two:

org.gnome.settings-daemon.plugins.power lid-close-battery-action

and

org.gnome.settings-daemon.plugins.power lid-close-ac-action

cclark gravatar imagecclark ( 2013-10-23 15:25:34 -0500 )edit

Read this: https://bugzilla.gnome.org/show_bug.cgi?id=687277

The option has been removed in Gnome Shell 2.6.

You can try to use systemd-inhibit (read the comments in the bug report):

systemd-inhibit --what=handle-lid-switch --who=me --why=because --mode=block /bin/sh

maarten gravatar imagemaarten ( 2013-10-23 20:32:47 -0500 )edit

You can temporarily change this behavior with office-runner. A screenshot can be found at http://worldofgnome.org/running-in-the-office-with-gnome/ . At the moment it is only available in Fedora 20+. See https://bugzilla.redhat.com/show_bug.cgi?id=998238 for the discussion. A release for Fedora 19 will be done soon. See https://admin.fedoraproject.org/pkgdb/acls/name/office-runner for the status.

maarten gravatar imagemaarten ( 2013-10-23 21:04:12 -0500 )edit

I'm trying to achieve the opposite - I DO want the laptop to suspend when the lid is closed. I see this is now handled by systemd (in the bugzilla link posted above) but my systemd logind.conf already has the line: HandleLidSwitch=suspend and the laptop still remains on with the screen & backlight on when the lid is closed.

cclark gravatar imagecclark ( 2013-10-24 08:44:19 -0500 )edit

2 Answers

Sort by » oldest newest most voted
0

answered 2013-10-24 06:01:15 -0500

skytux gravatar image

I'm not sure if this is what you are looking for, but if you don't want your laptop to suspend when you close the lid, then you have to edit the file /etc/systemd/logind.conf and add the following line to it:

HandleLidSwitch=ignore

It used to work for me in the past, but not sure if it does now.

HTH,

Germán.

edit flag offensive delete link more

Comments

excelent! Thank you - it works for me! Fedora 20

jnav gravatar imagejnav ( 2014-02-02 11:43:41 -0500 )edit

Glad it helped... good luck!

skytux gravatar imageskytux ( 2014-02-02 11:58:54 -0500 )edit
0

answered 2014-08-19 00:37:49 -0500

this post is marked as community wiki

This post is a wiki. Anyone with karma >750 is welcome to improve it.

Hello I am new to fedora, basically new to linux. when I tried the command : /etc/systemd/logind.conf in the terminal it said that the permission is denied.( bash: /etc/systemd/logind.conf: Permission denied). I will be extremely thankful to you if you could let me know how I should proceed.

edit flag offensive delete link more

Comments

You have to do:

echo "HandleLidSwitch=ignore" >> /etc/systemd/logind.conf
abadrinath gravatar imageabadrinath ( 2014-08-19 01:40:33 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2013-10-23 14:02:10 -0500

Seen: 10,757 times

Last updated: Aug 19 '14