Ask Your Question
0

GNOME desktop cannot load after installing Fglrx

asked 2013-10-20 11:25:54 -0500

darthwalrus gravatar image

updated 2013-10-20 12:24:15 -0500

After following the instructions at hxxp://fedoraproject.org/wiki/Fglrx, my GNOME desktop envrionment cannot load with a generic "Oh no, something went wrong" error screen, only offering the ability to log out.

Any advice on either how to complete the installation of the propitiatory drivers or even to rollback to the original ones would be most appreciated.

I am running the latest release of Fedora 19, fully 'yum upgrade''d.

Regards, Will

Edit: I didn't realise those drivers weren't maintained... that explains so much. How am I supposed to get maintained drivers? From the official AMD site?

edit retag flag offensive close merge delete

Comments

I have taken a look at the driver from the official AMD site (http://support.amd.com/en-us/download/desktop?os=Linux%20x86_64), but these seem only to be compatible with Fedora 10 or earlier (execute: ./amd*.run --listpkg). So as far as I know the stock drivers are the best choice.

Marc lml gravatar imageMarc lml ( 2013-10-22 13:46:45 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-10-20 12:03:47 -0500

Marc lml gravatar image

updated 2013-10-20 12:06:45 -0500

Remove the drivers with yum.

yum remove kmod-catalyst*
yum remove akmod-catalyst*

Remove xorg.conf

rm /etc/X11/xorg.conf

Edit /boot/grub2/grub.cfg and remove radeon.modeset=0 rd.driver.blacklist=radeon.

Example before editing

linux /boot/vmlinuz-3.10.12-100.fc18.x86_64 root=UUID=e39b2bba-0709-4e67-89b6-c8ebcf89592f ro rd.md=0 rd.lvm=0 rd.dm=0 rd.luks=0 vconsole.keymap=us rhgb quiet LANG=en_US.UTF-8 KEYTABLE=us

Example after editing

linux /boot/vmlinuz-3.10.12-100.fc18.x86_64 root=UUID=e39b2bba-0709-4e67-89b6-c8ebcf89592f ro rd.md=0 rd.lvm=0 rd.dm=0 rd.luks=0 vconsole.keymap=us rhgb quiet LANG=en_US.UTF-8 KEYTABLE=us radeon.modeset=0 rd.driver.blacklist=radeon

The ATI drivers from RPM Fusion are no longer maintained. Therefore I do not use them any more.

edit flag offensive delete link more

Comments

You'll want to check /etc/default/grub as well, so that when /boot/grub2/grub.cfg is regenerated it won't have the blacklist strings.

randomuser gravatar imagerandomuser ( 2013-10-20 19:43:14 -0500 )edit

Question Tools

Stats

Asked: 2013-10-20 11:25:54 -0500

Seen: 2,032 times

Last updated: Oct 20 '13