Ask Your Question
0

Fedora 19 - Blank screen after sleep resume

asked 2013-10-14 23:14:44 -0500

exittheory gravatar image

updated 2013-10-14 23:31:51 -0500

Hey everyone. Just installed Fedora 19 on my HP Pavilion m6-1035dx w/ an AMD A10-4600 APU. Everything's working perfectly alright - save for sleep mode. When I shut my laptop (and my lid switch triggers the auto sleep), things are okay. But when I attempt to resume my session, all I get is a vacant black screen. I know that it isn't frozen, because I am still able to adjust the audio output level with the dedicated volume adjustment keys (I know this because the sample pop sound increases/decreases accordingly). Also, the type of black screen I'm getting is without backlight - it's as if my display has been completely shut off.

I've uncommented the handleLidSwitch option in logind.conf (/etc/systemd) and set it equal to "ignore" as to avoid going into sleep mode when I seek to close my laptop lid. However, I'm still looking for a permanent solution. Any help would be totally appreciated.

EDIT: gnome 3 is my primary desktop environment

edit retag flag offensive close merge delete

Comments

I'm having this same problem with the AMD A4-4300M APU with AMD Radeon HD 7420G graphics. Suspend/resume worked for me briefly -- with the AMD Catalyst 13.6 beta driver. It hasn't worked since with with subsequent versions of Catalyst or the open Radeon driver.

Steven Rosenberg gravatar imageSteven Rosenberg ( 2013-10-18 14:14:22 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-10-21 01:53:30 -0500

taosld gravatar image

updated 2013-10-21 02:49:55 -0500

I am having this problem on Fedora 19 with Gnome3 and Cinnamon on a Lenovo IdeaPad Z575 (12992KU) Notebook with AMD Radeon HD 6620G. The screensaver function works fine (screen goes blank and comes back in response to mouse or key event). When I put the computer to sleep and then resume, I never get the screen to come back on.

At the black screen, I can do a reboot as follows: type Ctl-Alt-F2 to get into a virtual terminal; log in blind (user name then password); type in command "su -c 'reboot'" followed by the root password. The laptop does a reboot and screen is normal after.

I'd really appreciate some help fixing this problem. I'm trying to move away from Windows and need sleep functionality when I'm away from my office.

Thank you, exittheory, for your suggestion on the handleLidSwitch option in logind.conf (/etc/systemd). I made that change and it prevents sleep mode when closing the lid. That's very helpful!

I'm sorry if I've violated the group's protocol. I meant for my remarks to be a comment to the original question, but I could not see a link for adding comments.

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-10-14 23:14:44 -0500

Seen: 1,449 times

Last updated: Oct 21 '13