Ask Your Question
0

fc18 custom install CD issues

asked 2013-10-11 13:24:13 -0500

Trenin gravatar image

updated 2014-09-30 21:35:09 -0500

mether gravatar image

Hello.

I am trying to create an installation CD for Fedora 18 containing some base fedora packages plus a few of our own packages. It is a fairly minimal installation, so it doesn't include a lot of extras.

We've been able to do this quite easily with fedora 16 and earlier, but we are having quite a lot of trouble with fedora 18.

When we create a network installation DVD, everything seems to work fine. We point the repos to our local repositories which are hosting all of the fedora rpms and our custom rpms. The only issue is that the kickstart directive "reboot --eject" seems to be ignored. The DVD is not ejected, so on the next boot, the installation starts all over unless we manually remove the DVD.

The bigger issue is for the self contained DVD. Our isolinux.cfg file is as follows:

kernel vmlinuz
append initrd=initrd.img root=live:CDLABEL=product ks=cdrom:/dev/cdrom:/ks.cfg biosdevname=0

The kickstart file is as follows:

selinux --disabled
auth --enableshadow --passalgo=sha512
# Use CDROM installation media
install
cdrom
lang en_CA.UTF-8
# Run the Setup Agent on first boot
#firstboot --enable
keyboard --vckeymap=us --xlayouts='us'
# Network information
network --device=p2p1 --bootproto=dhcp --onboot=on --activate
# Root password
rootpw  --iscrypted <encrypted password>
# System timezone
timezone US/Eastern --isUtc
# System bootloader configuration
zerombr
bootloader --location=mbr --boot-drive=sda
# Partition clearing information
...
# Eject the disk after boot
reboot --eject
xconfig --startxonboot
# Packages
%packages --excludedocs --nobase
...
%end

The installation seems to start, but it is very slow, and our custom packages are not picked up. It turns out that it is ignoring the installation disc and using the online yum repositories instead defined in /etc/anaconda.repos.d!

If I disable the network to try to force it to use the disc, then it complains about not having a valid installation source. If I click on that and verify, verification seems to say it is valid, but the main page still says there is an invalid installation source. I see the following messages in /tmp/packaging.log:

DEBUG packaging: getting release version from tree at file:///mnt/install/source (18)
DEBUG packaging: retrieving treefinfo from file:///mnt/install/source (proxies: {} ; sslverify: True)    
INFO packaging: Error downloading treeinfo: [Errno 14] Could not open/read file:///mnt/install/source/treeinfo
...
ERR packaging: base repo (cdrom/file:///mnt/install/source) not valid -- removing it

I have verified that /mnt/install/source is in fact empty, but I don't understand why it is looking there. The files are on the DVD in the Packages directory, and a repo was created, so there is a valid repodata directory as well on the DVD.

I have tried adding a manual repo to /run/initramfs/live in the ks.cfg (since that location seems to have a copy of the DVD), and while that seems to work when the online repos are working (i.e. custom packages are recognized), if I disable online repos ... (more)

edit retag flag offensive close merge delete

Comments

How is the part looking refering to the repos?

Oh yes, and be aware that, if you change the repo in %post, you also must mount the local repo there first, most likley requiring as well the server credentials...

sea gravatar imagesea ( 2013-10-11 16:44:47 -0500 )edit

There is no part referring to repos. It wasn't required in Fedora 16, so I don't have it now. Simply saying 'CDROM' was enough for it to install from the DVD in Fedora 16, but no longer. Now, when I did try faking it out for fedora 18, I had 'repo --name=all --baseurl=/run/initramfs/live' and it recognized the repo on the CD and installed the custom packages, but only if the network was enabled. If I disabled the network, it failed with the above error even though all the required packages were on the DVD.

Trenin gravatar imageTrenin ( 2013-10-12 22:17:16 -0500 )edit

Fixed! I had to make the following change to the isolinux.cfg file. append initrd=initrd.img inst.stage2=cdrom:CDLABEL=product ks=cdrom:/dev/cdrom:/ks.cfg biosdevname=0

Trenin gravatar imageTrenin ( 2013-10-16 12:24:54 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-10-16 12:25:59 -0500

Trenin gravatar image

Fixed!!

I needed to make a change to the isolinux.cfg file to point to the cdrom for stage2. This mounted the disc properly so that the packages could then be seen!

append initrd=initrd.img inst.stage2=cdrom:CDLABEL=product ks=cdrom:/dev/cdrom:/ks.cfg biosdevname=0
edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-10-11 13:24:13 -0500

Seen: 785 times

Last updated: Oct 16 '13