Ask Your Question
4

how to set console larger console font

asked 2013-09-28 06:48:21 -0500

kobuck gravatar image

updated 2014-09-28 21:33:02 -0500

mether gravatar image

My monitor is 1920x1080 and the default font size is too small. How can i increase the size of the virtual console fonts?

Thanks to linux.alder I have been able to determine that latarcyrheb-sun32 font gives me an acceptable character size. However, using the commandline parameter for vconsole.font does not affect the bootup font being used by the virtual consoles. Am I seeing a condition worthy of a bug report or do I need more education??


I decided to submit a bugzilla report, but found there are many entries identifying the fact that vconsole.conf as "being ignored/has no effect". Further, in reading several of these reports, I did not find any clear understanding of a resolution path. I don't know how to add a bug report that would add any insight to the current situation. I don't even know what component I would attribute the bug to. So For now I'm going to live with a "setfont latarcyrheb-sun32" whenever I need to use the virtual console on my 2 machines.

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
2

answered 2013-09-28 16:41:51 -0500

linux.alder gravatar image

I think you are looking to change the font in the virtual consoles. Not gnome-terminal. If so, you will need to edit the /etc/default/grub file, changing the value of "vconsole.font" on the "GRUB_CMDLINE_LINUX" line to whatever font you want. Then remake grub2. You can temporarily change the virtual console font by running "setfont <fontname>", using of the fonts in /lib/kbd/consolefonts. (ie. setfont lat9v-12)

Whomever thought this was better than the old i18n hack should be smacked around a bit! IMHO

edit flag offensive delete link more

Comments

You're right I'm trying to affect the virtual console sizes. Current value is vconsole.font=latarcyrheb-sun16 and ~sun32 does the trick.

kobuck gravatar imagekobuck ( 2013-09-29 10:04:42 -0500 )edit

Welll... the setfont latarcyrheb-sun32 works and demonstrates that a new fontsize solves my problem. However, after editing the /etc/default/grub then doing the 'grub2-mkconfig -o /boot/grub2/grub.cfg' , and then verifying the desired vconsole.font=latarcyrheb-sun32 is in place, I rebooted and found this parameter did not affect the virtual console font.

kobuck gravatar imagekobuck ( 2013-09-29 13:06:02 -0500 )edit

Try editing /etc/vconsole.conf with same value(latacyrheb-sun32). Seems there are multiple places. Technology in motion I guess.

linux.alder gravatar imagelinux.alder ( 2013-09-29 13:52:59 -0500 )edit

See man vconsole.conf for more information . As you can see there, systemd-vconsole-setup is who controls everything about it

q2dg gravatar imageq2dg ( 2013-09-29 16:27:43 -0500 )edit
1

Per the man vconsole.conf, setting the font in this file should affect the virtual consoles. Setting the font via the vconsole.font= on the command line should overide the value in the vconsole.conf file. On my 2 F19 machines I cannot change to the latarcyrheb-sun32 font using the above methods. The only thing that has worked so far is the "setfont" command.

kobuck gravatar imagekobuck ( 2013-09-30 00:08:26 -0500 )edit
0

answered 2013-09-28 15:42:00 -0500

jmt gravatar image

You don't mention which desktop you are using so I'll just assume you are using the default Gnome desktop.

There are (at least) two ways to accomplish this:

  1. Open a terminal (gnome-terminal) and choose "Profile preferences" from the Edit menu. Uncheck "Use the system fixed width font" and select your own font and size.

  2. Use gnome-tweak-tool to change the default monospace font.

edit flag offensive delete link more

Comments

1

That's correct but it only applies to the Gnome terminal emulator. The original question was about the linux text console, which is something else.

mitchenerg gravatar imagemitchenerg ( 2014-10-17 09:42:15 -0500 )edit

Question Tools

Stats

Asked: 2013-09-28 06:48:21 -0500

Seen: 11,386 times

Last updated: Sep 30 '13