Ask Your Question
0

Downgrading libreoffice

asked 2013-09-27 09:06:42 -0500

tntrush gravatar image

Hallo,

I recently updated to libreoffice-1:4.1.2.2-1.fc19.x86_64 which a certain bug that does not permit me to accomplish my work.

I would like to downgrade to the previous version: libreoffice-1:4.1.1.2-5.fc19.x86_64.

I tried with the command : yum downgrade libreoffice

but it does not seem to work.

Error: Package: 1:libreoffice-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
           Requires: libreoffice-draw = 1:4.1.0.0-9.beta2.fc19
           Installed: 1:libreoffice-draw-4.1.2.2-1.fc19.x86_64 (@updates)
               libreoffice-draw = 1:4.1.2.2-1.fc19
           Available: 1:libreoffice-draw-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
               libreoffice-draw = 1:4.1.0.0-9.beta2.fc19
Error: Package: 1:libreoffice-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
           Requires: libreoffice-emailmerge = 1:4.1.0.0-9.beta2.fc19
           Installed: 1:libreoffice-emailmerge-4.1.2.2-1.fc19.x86_64 (@updates)
               libreoffice-emailmerge = 1:4.1.2.2-1.fc19
           Available: 1:libreoffice-emailmerge-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
               libreoffice-emailmerge = 1:4.1.0.0-9.beta2.fc19
Error: Package: 1:libreoffice-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
           Requires: libreoffice-base = 1:4.1.0.0-9.beta2.fc19
           Installed: 1:libreoffice-base-4.1.2.2-1.fc19.x86_64 (@updates)
               libreoffice-base = 1:4.1.2.2-1.fc19
           Available: 1:libreoffice-base-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
               libreoffice-base = 1:4.1.0.0-9.beta2.fc19
Error: Package: 1:libreoffice-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
           Requires: libreoffice-impress = 1:4.1.0.0-9.beta2.fc19
           Installed: 1:libreoffice-impress-4.1.2.2-1.fc19.x86_64 (@updates)
               libreoffice-impress = 1:4.1.2.2-1.fc19
           Available: 1:libreoffice-impress-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
               libreoffice-impress = 1:4.1.0.0-9.beta2.fc19
Error: Package: 1:libreoffice-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
           Requires: libreoffice-calc = 1:4.1.0.0-9.beta2.fc19
           Installed: 1:libreoffice-calc-4.1.2.2-1.fc19.x86_64 (@updates)
               libreoffice-calc = 1:4.1.2.2-1.fc19
           Available: 1:libreoffice-calc-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
               libreoffice-calc = 1:4.1.0.0-9.beta2.fc19
Error: Package: 1:libreoffice-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
           Requires: libreoffice-writer = 1:4.1.0.0-9.beta2.fc19
           Installed: 1:libreoffice-writer-4.1.2.2-1.fc19.x86_64 (@updates)
               libreoffice-writer = 1:4.1.2.2-1.fc19
           Available: 1:libreoffice-writer-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
               libreoffice-writer = 1:4.1.0.0-9.beta2.fc19
Error: Package: 1:libreoffice-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
           Requires: libreoffice-math = 1:4.1.0.0-9.beta2.fc19
           Installed: 1:libreoffice-math-4.1.2.2-1.fc19.x86_64 (@updates)
               libreoffice-math = 1:4.1.2.2-1.fc19
           Available: 1:libreoffice-math-4.1.0.0-9.beta2.fc19.x86_64 (fedora)
               libreoffice-math = 1:4.1.0.0-9.beta2.fc19
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I would appreciate your help.

Kind regards, tntrush

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-09-27 11:29:51 -0500

marcindulak gravatar image

This will downgrade to the version available from the fedora repo, and not the previous release available in the past in the updates repo:

yum downgrade libreoffice*

After that consider excluding libreoffice updates:

echo "exclude=libreoffice*" >> /etc/yum.conf
edit flag offensive delete link more
0

answered 2013-09-28 06:12:28 -0500

tntrush gravatar image

Thanx, everything works great now.

:-)

Kind regards, tntrush

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-09-27 09:06:42 -0500

Seen: 578 times

Last updated: Sep 28 '13