Ask Your Question
2

mpirun: command not found...

asked 2013-09-23 13:46:50 -0500

Sundyp Krishna gravatar image

updated 2013-09-24 06:54:24 -0500

FranciscoD_ gravatar image
[root@localhost Documents]# yum install openmpi
Loaded plugins: langpacks, presto, refresh-packagekit
Package openmpi-1.6.3-7.fc18.x86_64 already installed and latest version
Nothing to do
[root@localhost Documents]# mpirun -np 4 -mpi btl ^openib mpi1
bash: mpirun: command not found...

wha's reason behind this... pls sort out this prob...

edit retag flag offensive close merge delete

2 Answers

Sort by » oldest newest most voted
3

answered 2013-09-23 13:50:05 -0500

marcindulak gravatar image

updated 2013-09-24 07:38:20 -0500

openmpi on Fedora is handled by environment-modules (since RHEL6), so you need:

module load mpi/openmpi-x86_64

You can include this in ~/.bashrc for making it permanent.

Check for available mpi modules with:

module avail mpi
edit flag offensive delete link more

Comments

Where is module in Fedora 21?

alfC gravatar imagealfC ( 2014-12-11 21:38:09 -0500 )edit

su -c "yum -y install openmpi"; source /etc/profile.d/modules.sh . After that the module command (it's a shell function, or alias depending on your shell) will become available.

marcindulak gravatar imagemarcindulak ( 2014-12-14 23:51:33 -0500 )edit
-1

answered 2013-09-23 13:57:06 -0500

Amit Caleechurn gravatar image

Add “PATH=$PATH:/usr/lib64/openmpi/bin” without quotes to your .bash_profile so that you don’t need to type the entire “/usr/lib64/openmpi/bin” path repeatedly. Or as a temporary fix issue:

$ export PATH=$PATH:/usr/lib64/openmpi/bin
edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-09-23 13:46:50 -0500

Seen: 26,902 times

Last updated: Sep 24 '13