Ask Your Question
1

nvidia proprietary driver vs. kernel update causes fedora 19 to not boot

asked 2013-09-22 01:18:14 -0500

elwood gravatar image

updated 2013-10-28 13:39:25 -0500

Hello again,

Are nvidia card users (mine is gtx 550 ti) SOL when it comes to being able to install the proprietary driver then do a kernel update/upgrade?

My system refuses to boot up when I install the proprietary driver from rpmfusion, then do a kernel update. I thought that the new kernel was a security update which should still work with the installed graphics driver, but I can't figure out how to make it work that way.

Is there any safe way to install the driver and have the new kernel (or any kernel for that matter) boot to the Gnome desktop?

I sure can't figure out how to do it, but I must be missing something I guess. The recovery mode (or similar) won't even boot to desktop.

I've been following the guide at "if not true, then false" web site.

Thanks for any help you may provide, I could really use some guidance here.

edit retag flag offensive close merge delete

Comments

I am experiencing what sounds like the same issue. Just after the Fedora 19 splash a page of text pops up and "plymouth boot to quit" (or something like that) fails to load and hangs the system there. However on system start grub does give me the option of choosing the current or previous kernel, I choose the previous kernel and it boots up fine. All I could suggest is find a way to roll back to the previous kernel (Linux 3.10.11-200.fc19.x86_64 x86_64) as it does work for me with a NVIDIA Corporation GF108 [GeForce GT 620].

Tinker gravatar imageTinker ( 2013-09-22 04:20:38 -0500 )edit

3 Answers

Sort by » oldest newest most voted
6

answered 2013-09-22 17:51:12 -0500

Gareth Jones gravatar image

There is a known incompatibility between Linux 3.11 and the current RPM Fusion {a,}kmod-nvidia packages. There are manually-installable RPMs available in the meantime: http://www.forums.fedoraforum.org/showthread.php?t=294091

edit flag offensive delete link more

Comments

Thank you Gareth Jones. That did the trick, I now have graphics acceleration so I can play the games I've downloaded. I can't tell you how much I appreciate your help.

elwood gravatar imageelwood ( 2013-09-26 04:32:44 -0500 )edit

No problem. If this answer solved the problem, you should “accept” it (click the tick to the left), so that others with the same problem can easily see what to do (and incidentally, I get karma ;)

Gareth Jones gravatar imageGareth Jones ( 2013-09-26 10:52:52 -0500 )edit
0

answered 2013-10-28 13:43:35 -0500

elwood gravatar image

I'm having the same problem again. The admod builds itself when I try to boot up, but then a lot of gibberish (to me) appears on the screen and it never reaches the Gnome desktop.

I have since reinstalled and updated Fedora 19, but I have not and probably won't install the nvidia proprietary driver again.

I guess I'll have to keep XP for my games and not use F19 for gaming at all.

edit flag offensive delete link more

Comments

Never using the proprietary driver is always a good idea... At least, you'll (almost) never have to worry again when updating your operating system ;-)

remjg gravatar imageremjg ( 2013-10-28 15:34:01 -0500 )edit

Hmm, well, I guess I'll probably be an early adopter of SteamOS, meanwhile I'm going to look for a distro with better nvidia support...

elwood gravatar imageelwood ( 2013-10-28 19:38:41 -0500 )edit
0

answered 2013-09-22 16:25:04 -0500

Amit Caleechurn gravatar image

You're probably using kmod instead of akmod which is supposed to check if there are any missing kmods and if so, rebuild a new kmod for you. Refer to http://rpmfusion.org/Howto/nVidia

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-09-22 01:18:14 -0500

Seen: 6,790 times

Last updated: Oct 28 '13