Ask Your Question
0

NFS autostart

asked 2013-09-21 04:15:48 -0500

Mohan G gravatar image

updated 2013-09-21 18:44:18 -0500

FranciscoD_ gravatar image

I have installed NFS server on my home-server (Fedora-19) and enabled it with the following commands.

systemctl enable nfs-lock.service
systemctl enable nfs-server.service
systemctl start  nfs-lock.service
systemctl start  nfs-server.service

This works fine and I cound mount the NFS directories (in /etc/exports) on another machine. But if restart the server machine, NFS server will not start automatically. I have to start the service manually after every restart. Can anyone tell me the proper way to enable NFS server.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-09-21 07:16:25 -0500

marcindulak gravatar image

I guess it's https://bugzilla.redhat.com/show_bug.cgi?id=970595. You need either to:

systemctl enable nfs-lock.service
systemctl enable nfs.target

or:

yum remove nfs-utils
yum install nfs-utils

If you experience issues with nfs version 4 - see https://ask.fedoraproject.org/question/30612/nfs-gss-problems-on-f19/ . If you want firewall on - see https://ask.fedoraproject.org/question/9864/how-to-correct-firewalld-in-fedora18-to-allow-nfs-access/ - but i think the solution provided in that answer may be incomplete - there are more dynamic ports used by nfs. If you experience problems just ask another question - i have some notes how to lock nfs port numbers.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-09-21 04:15:48 -0500

Seen: 3,667 times

Last updated: Sep 21 '13