Ask Your Question
0

fedora 17 3.9.10 freezes on boot after /sbin/init 0

asked 2013-09-20 15:52:44 -0500

mjmael gravatar image

Hi all, I turned off the GUI with /sbin/init 3. I wanted to put the GUI back on, and went for /sbin/init 0 (I was sure as hell it was the right number... turns out it should have been /sbin/init 5). Now my fedora freezes on boot. I can access recovery mode where :

  • I tried to type "/sbin/init 5" in the command line. I get the log : nvidia: module license 'NVIDIA' taints kernel. Disabling lock debugging due to kernel taint NVRM: No NVIDIA graphics adapter found!

  • I tried to set graphical as the default target : "ln -s /lib/systemd/system/graphical.target /etc/systemd/system/default.target"

Then I look for drivers for NVIDIA because of the error message but the command "lspci | grep -i VGA" returns "Intel Corporation Device 0166 (rev 09)", so it looks like it is looking for some NVIDIA card I don't have...

Any help/ideas would be appreciated !

M.

edit retag flag offensive close merge delete

Comments

What did you do in order to change the init level?

shaiton gravatar imageshaiton ( 2013-09-20 16:21:27 -0500 )edit
1

Check if you have any nvidia packages installed by running rpm -qa | grep nvidia , remove any matching packages. Inspect the /etc/X11 directory (sub directories) for any remaining nvidia config files. Remove the /etc/X11/xorg.conf and reboot your machine to allow the system to auto detect your display settings.

Amit Caleechurn gravatar imageAmit Caleechurn ( 2013-09-21 17:10:36 -0500 )edit

Yes, it worked like a charm ! Thanks a lot. I did not have a /etc/X11/xorg.conf so i just deleted the xorg.conf.nvidia*. It rebooted with no problems !

mjmael gravatar imagemjmael ( 2013-09-22 09:45:58 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-09-20 16:23:04 -0500

shaiton gravatar image

You might be able to boot as single user mode (init 1) by adding a 1 at the end of the boot parameters at grub, then, revert your change to start with init 5 by default.

edit flag offensive delete link more
0

answered 2013-09-21 12:44:44 -0500

mjmael gravatar image

updated 2013-09-22 09:50:29 -0500

Hi, So I was trying to install CUDA.

But it turns out I don't have a nvidia card (cf lspci | grep VGA previously).

When I turned down my GUI (/sbin/init 3) and realized I had no nvidia, I tried to turn the GUI back on (/sbin/init 5) with no success ( error message in the first post).

Now when I reboot, I get stuck on boot. However, I can access the rescue mode where I logged with sbin/init 3 and then tried to launch the GUI with sbin/init 5 : error.

I also uninstall cuda to make sure this was not the problem. Still it seems to be looking for some nvidia somewhere.

My guess would be to uninstall some file system that would be asking for this nvidia, but I don't know where that is...

EDIT : So like Amit Caleechurn said I did :

  • rpm -qa | grep nvidia to find the nvidia related packages
  • deleted all those packages
  • deleted the /etc/X11/xorg.conf.nvidia* files
  • rebooted => worked like a charm

Thanks for your time,

Matthieu

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-09-20 15:52:44 -0500

Seen: 307 times

Last updated: Sep 22 '13