Why does changing the desktop settings for the clock prevent me from logging in?

asked 2013-09-19 17:56:42 -0500

markito3 gravatar image

updated 2013-10-27 12:16:12 -0500

When I change some of my gsettings, subsequent logins hang after accepting my password. The desktop never comes up. To get out of this situation, the only solution I've found is to delete the .config/dconf/user file in my home area. Not a great option.

In particular, either one of these two is sufficient to cause the problem:

  1. org.gnome.desktop.interface clock-format '12h'
  2. org.gnome.desktop.interface clock-show-date true

I also find that when the login process is hung, you see an instance of /usr/libexec/gnome-session-failed running (using the Ctrl-Alt-F2 trick). After clearing the file in .config, it is not there.

edit retag flag offensive close merge delete

Comments

This sounds like a bug. Have you looked for a similar bug report?

randomuser gravatar imagerandomuser ( 2013-09-26 01:43:40 -0500 )edit

Following this forum thread, maybe it's an issue related to the locale settings. You may go to the Region & Language entry of the GNOME settings and check if everything is configured.

remjg gravatar imageremjg ( 2013-10-27 12:41:03 -0500 )edit