Ask Your Question

Dependency on a library

asked 2013-09-10 03:03:34 -0500

Thakur Rajesh Singh gravatar image

updated 2014-09-30 11:12:42 -0500

mether gravatar image

Hi i have fedora 19-64 bit installed. I am unable to run an EDA tool which is showing error due to missing in shared libraries. Actually the tool despite being the latest version is officially supported on RHEL-4 only !! I was able to install but not which was only available till fedora8 . i tried to install by building the src.rpm of the file libtermcap-2.0.8-47.src.rpm of fedora8 from rpm bone but the build also fails due to dependency. how to install this dependency in fedora 19. Please help me. I need a workaround.

edit retag flag offensive close merge delete



maybe this helps, in CentOS 6.4 (similar to RHEL 6.4) is provided by compat-libtermcap-2.0.8-49.el6

also which dependencies do you require for building the source rpm?

Jann5s gravatar imageJann5s ( 2013-09-10 03:18:07 -0500 )edit

Hi Jann5s , thanks for the reply, i was using centos 6.4 before i moved on from centos6.4 to fedora, now my lappy currently doesnt have any space for a dual boot. actually i was able to build from src.rpm but yum or rpm is not installing it giving a msg that it is obsoleted by ncurses. is there a way to force install by some -f option. i will try that and report back. thnx for the info.

Thakur Rajesh Singh gravatar imageThakur Rajesh Singh ( 2013-09-10 05:32:21 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-09-10 04:20:38 -0500

marcindulak gravatar image

I would recommend using CentOS 6 for the purpose of using your software. CentOS provides in the compat-libtermcap package. Possible workarounds on Fedora include creating a link (see

ln -s /lib64/ /lib64/

or rpmbuild --rebuild the el6 compat-libtermcap (

edit flag offensive delete link more



Hi marcindulak, thanks frnd for the tips. i will try and report back.

Thakur Rajesh Singh gravatar imageThakur Rajesh Singh ( 2013-09-10 05:33:17 -0500 )edit

Hi marcindulak , i had earlier tried to create a soft link to /lib64/ to /lib64/ but that did not work. But i now tried your soft linking solution and it worked !! Thanks a lot friend for helping me. Fedora community rocks !!

Thakur Rajesh Singh gravatar imageThakur Rajesh Singh ( 2013-09-10 05:44:48 -0500 )edit

answered 2013-10-29 19:53:47 -0500

Gus gravatar image

updated 2013-10-30 07:15:58 -0500

The symlink above is backwards... the exists, does not.

# ln -s /lib64/ /lib64/

This approach (replacement library pointer) worked for me on CentOS 6.4.

edit flag offensive delete link more

Question Tools


Asked: 2013-09-10 03:03:34 -0500

Seen: 4,505 times

Last updated: Oct 30 '13