Ask Your Question
0

Fedora 19 boot time slow

asked 2013-09-07 15:49:24 -0500

updated 2013-09-07 20:55:00 -0500

FranciscoD_ gravatar image

Hi,

This has been driving me nuts. Fedora 19 is extemely slow to boot. The main culprits according to systemd-analyze are:

     16.128s firewalld.service
     15.081s gdm.service

I was highly tempted to disable firewalld, but rather would like to understand what I can do to improve it and boot time overall. I boot in text mode rather than graphical, and its annoying to see the rest of the boot happen quickly only to stale waiting for these 2 processes to complete.

Any ideas/suggestions welcome?

Cheers, Jon

edit retag flag offensive close merge delete

Comments

Your best bet is to file a bug.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-09-07 20:54:37 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
0

answered 2015-10-11 12:24:09 -0500

I know it's a bit old question, but I had similar issue on Fedora 22 and it took me a while to find an answer.

If your systemd-analyze blame lists absurdly long time to boot firewalld.service , please take a look at this post: https://ask.fedoraproject.org/en/ques...

There seems to be a bug where /var/lib/ebtables/lock file can get to locked state and firewalld hangs on it. I don't know what's the cause, but deleting the locked file seems to fix the problem.

edit flag offensive delete link more
0

answered 2013-09-07 16:51:04 -0500

sideburns gravatar image

If you're booting into text mode and using (I presume) startx to get to a GUI, there's no reason in the world to have gdm, the Gnome Display Manager, running. That's the program that Gnome uses to provide a graphical login screen, and once you're logged in, you've no use for it. (BTW, if you're not using Gnome, you can get rid of it completely. If you are, you may not be able to. The last time I checked, gnome-shell required it, along with some other gnome-specific stuph.) Run this command as root, then reboot and see if it helps:

systemctl mask gdm.service

I recommend using mask instead of disable, because disable only keeps it from starting on its own; other programs can still drag it in. If the service is masked, systemd can't start it at all until it's unmasked.

edit flag offensive delete link more

Comments

Hey,

Cheers for the answer, however, at least of the moment, I'm happy for GDM to start up at the end, just wonder why it takes so longer (does seem excessive). Ditto firewalld excessive startup time.

jondkent gravatar imagejondkent ( 2013-09-07 17:07:53 -0500 )edit

Shrug! Having gdm take 15 seconds to load when you're not using it is part of the reason your computer takes so long to boot. Turning it off would make your computer boot quicker, but if you don't want to, it's your computer, not mine.

sideburns gravatar imagesideburns ( 2013-09-07 19:02:28 -0500 )edit

Question Tools

Stats

Asked: 2013-09-07 15:49:24 -0500

Seen: 2,110 times

Last updated: Sep 07 '13