Ask Your Question
0

Gnome shell changed with latest Fedora 19 update.

asked 2013-09-06 08:48:26 -0500

karandeepchahal gravatar image

updated 2014-02-16 08:22:00 -0500

mether gravatar image

I updated my fedora and the Gnome shell looks different. I want the old one back but cannot find any settings in the tweak tool to do this. How can I revert the look back to the way it was?

New Gnome shell has a white bar on the top and a white bar on the bottom (like classic gnome 2.0 bar with all windows).

edit:

I did not change any shell themes. Although, I did do a "yum autoremove". Did I accidentally remove anything?

chahal@hades:~$ rpm -qa |grep gnome-shell
gnome-shell-extension-window-list-3.8.3.1-1.fc19.noarch
gnome-shell-extension-places-menu-3.8.3.1-1.fc19.noarch
gnome-shell-extension-user-theme-3.8.3.1-1.fc19.noarch
gnome-shell-extension-alternate-tab-3.8.3.1-1.fc19.noarch
gnome-shell-extension-launch-new-instance-3.8.3.1-1.fc19.noarch
gnome-shell-extension-common-3.8.3.1-1.fc19.noarch
gnome-shell-extension-apps-menu-3.8.3.1-1.fc19.noarch
gnome-shell-3.8.4-2.fc19.x86_64
chahal@hades:~$ yum history info
Loaded plugins: fastestmirror, langpacks, refresh-packagekit
You don't have access to the history DB.
chahal@hades:~$ sudo !!
sudo yum history info
[sudo] password for chahal: 
Loaded plugins: fastestmirror, langpacks, refresh-packagekit
Transaction ID : 257
Begin time     : Fri Sep  6 09:27:53 2013
Begin rpmdb    : 1828:4fc4ac8b58817dffa0a28625e483f955e1f28cb1
End time       :            09:28:06 2013 (13 seconds)
End rpmdb      : 1828:f2fdae47cdc0310ceddd12b002ccf19f29eb4ff2
User           : Karandeep Chahal <chahal>
Return-Code    : Success
Command Line   : update
Transaction performed with:
    Installed     rpm-4.11.1-1.fc19.x86_64                       @updates
    Installed     yum-3.4.3-106.fc19.noarch                      @updates
    Installed     yum-metadata-parser-1.1.4-8.fc19.x86_64        @fedora
    Installed     yum-plugin-fastestmirror-1.1.31-17.fc19.noarch @updates
Packages Altered:
    Updated ca-certificates-2012.87-10.4.fc19.noarch @updates
    Update                  2013.1.94-1.fc19.noarch  @updates
    Updated firefox-23.0.1-3.fc19.x86_64             @updates
    Update          23.0.1-4.fc19.x86_64             @updates
    Updated rhino-1.7R4-4.fc19.noarch                @updates
    Update        1.7R4-5.fc19.noarch                @updates
    Updated xulrunner-23.0.1-1.fc19.x86_64           @updates
    Update            23.0.1-4.fc19.x86_64           @updates
history info
chahal@hades:~$

edit:

I do not want the classic mode. I did not enable the classic mode. I want the normal mode. How can I get the normal mode back?

edit retag flag offensive close merge delete

4 Answers

Sort by ยป oldest newest most voted
0

answered 2013-09-06 09:26:23 -0500

shaiton gravatar image

No the update of your gnome-shell should not have change your theme. Please provide the url given by the url command: # yum history info |fpaste if you don't have network, run only the yum command and give us the result (yum history info).

Don't you have played with gnome plugins before rebooting?

Also please provide us the output of # rpm -qa |grep gnome-shell

edit flag offensive delete link more
1

answered 2013-09-06 10:06:31 -0500

karandeepchahal gravatar image

updated 2013-09-17 08:50:09 -0500

I fixed it by yum groupinstall gnome-shell or something. I think I messed it up when I did a yum autoremove. Updates had nothing to do with it.

edit flag offensive delete link more
1

answered 2013-09-06 10:53:21 -0500

hmaarrfk gravatar image

The new default for classic mode had a white looking theme.

Simply log into to Gnome Shell, and enable the extensions you want to bring it back to "classic" mode. while keeping the black look.

You can either use Gnome Tweak Tools or extensions.gnome.org

edit flag offensive delete link more
0

answered 2013-10-28 22:25:54 -0500

yum install gnome-session-xsession

I had a similar situation, in which a yum autoremove switched me back to Gnome classic. I checked against the packages in yum group install GNOME and noticed gnome-session-xsession was missing. Everything appears to be back to normal after installing the package and logging out.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-09-06 08:48:26 -0500

Seen: 2,817 times

Last updated: Oct 28 '13