Ask Your Question
0

nfs-server doesn't stay running in Fedora 19

asked 2013-09-03 19:07:35 -0500

nerfer gravatar image

updated 2013-09-03 21:33:50 -0500

FranciscoD_ gravatar image

I have an old 32-bit laptop that I installed Fedora 19 on (erasing the old Windoze XP). I have plenty of Unix experience from back in the day, but not at the system-admin level, so some of this is new to me. (When you mention files or environment variables, you'll have to tell me where they are found).

I also have the Embedded Linux Learning Kit that I want to connect to it, it's set up to mount using NFS. It tries to do this but fails, with the following message:

dm9000 dm9000: eth0: link up, 100Mbps, full-duplex, lpa 0xC5E1
     host=192.168.1.50, domain=, nis-domain=(none)
     bootserver=255.255.255.255, rootserver=192.168.1.2, rootpath=
VFS: Unable to mount root fs via NFS, trying floppy.
VFS: Cannot open root device "nfs" or unknown-block(2,0): error -6
Please append a correct "root=" boot option; here are the available partitions:
1f00             256 mtdblock0  (driver?)
1f01             128 mtdblock1  (driver?)
1f02            5120 mtdblock2  (driver?)
1f03          256640 mtdblock3  (driver?)
Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(2,0)

I installed NFS version 1:1.2.8-4.0fc19 for i686 arch. I read the 970595 bug report and I think I followed those instructions correctly. However, when I run system-ctl start nfs-server, I see in the service configuration UI that it shows it as stopped (completed). nfs-lock and some other services are still running. At other times when I've tried to start nfs-service, it gives me a list of stop and starts and ends with it stopped (maybe this is when I try to restart it, I just did a reboot of the system now to see what that would do).

The instructions for the kit talk about configuring /etc/sysconfig/ifcfg-eth0, but that's not on my system. I found a note on "Consistent Network Device Naming" saying for dedicated systems it's actually of the form em[n] or p<slot>p<port>_<vf>, not eth<n>. For me it seems to be ifcfg-enp2s0, which doesn't exactly match any of the so-called "consistent naming" description, but inside the file it does say TYPE=Ethernet. Does this sound right?

Couple more questions: some of the documentation refers to NFSv2, 3 or 4. How do I know what version I'm running? Do I need rpcbind running, does it hurt to have it running with NFSv4?

Thanks

edit retag flag offensive close merge delete

Comments

I guess it is version 4, there is a /etc/idmapd.conf. I myself have been configuring NFS for some time to mount some directory on a Raspberry pi but did not succeed. However removing firewalld do get UPnP working, maybe you should try it, too. Re-install firewalld if it did not work.

yanglifu90 gravatar imageyanglifu90 ( 2013-09-03 23:47:14 -0500 )edit

I have firewalld stopped, shouldn't that be enough? (I don't care about security as it is only one computer and the one device, no traffic, no internet access on ethernet).

nerfer gravatar imagenerfer ( 2013-09-04 13:46:12 -0500 )edit

Try to disable nfs version 4: set RPCNFSDARGS="--no-nfs-version 4" in /etc/sysconfig/nfs and systemctl restart nfs.service; systemctl stop firewalld.service

marcindulak gravatar imagemarcindulak ( 2013-09-05 07:04:50 -0500 )edit

Can you update your question with relevant lines from /etc/exports from the server?

randomuser gravatar imagerandomuser ( 2013-09-26 02:07:34 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2014-01-26 19:04:36 -0500

bill gravatar image

In fedora 19, they switch the nfs server to ganesha (fuse one), flexible with far more complex configuration file.

edit flag offensive delete link more

Comments

Do you have any references for that? I see nfs-ganesha is available - but not installed by default. And NFS works OOTB.

randomuser gravatar imagerandomuser ( 2014-01-27 17:41:10 -0500 )edit

Question Tools

Stats

Asked: 2013-09-03 19:07:35 -0500

Seen: 1,083 times

Last updated: Jan 26 '14