Can't authenticate with ssh key

asked 2013-09-03 10:23:25 -0500

duffy gravatar image

updated 2013-09-03 10:48:03 -0500

baptistemm gravatar image

I use GNOME 3, for better or worse. I noticed today I can't ssh into my remote hosts anymore.

When I type ssh-add on the terminal I get:

Could not open a connection to your
authentication agent.

If I type seahorse-daemon I get:

** (seahorse-daemon:24656): WARNING
**: Could not load desktop file '/etc/xdg/autostart/seahorse-daemon.desktop':
No such file or directory

If I type rpm -qa | grep seahorse I get:

seahorse-3.8.2-1.fc19.x86_64
seahorse-nautilus-3.8.0-1.fc19.x86_64

I'm lost. This is beyond me. I'm used to this just working. Help?

edit retag flag offensive close merge delete

Comments

1

Hi Mairin, I guess you tried to open the file /etc/xdg/autostart/seahorse-daemon.desktop that seahorse complains about (but it seems this is just a warning). Any relevant output if you run journalctl -b ? Did you also tried to kill the seahorse-daemon, and launch it back.

baptistemm gravatar imagebaptistemm ( 2013-09-03 10:53:04 -0500 )edit

Hey baptistemm, I couldn't figure it out and had to ssh to a remote host, so I ended up rebooting and that fixed it. If it happens again I will try journalctl -b.

duffy gravatar imageduffy ( 2013-09-03 12:59:11 -0500 )edit