Ask Your Question

Evince printer list

asked 2013-09-02 12:24:30 -0500

nkstanton1 gravatar image

updated 2014-09-28 11:41:05 -0500

mether gravatar image

In fedora 19 how can I prevent evince from listing so many printers? It lists 12, not just the 2 I configured. Other programs and cups only list the 2. I haven't seen this problem in fedora 17 or even earlier versions of fedora.

edit retag flag offensive close merge delete


I'm curious about this too. The printer dialog in evince seems to search for network printers all the time. It gets me confused.

hmaarrfk gravatar imagehmaarrfk ( 2013-09-02 17:28:59 -0500 )edit

Me to! It is quit annoying that evince is showing such a long list

tmensink gravatar imagetmensink ( 2013-11-13 04:22:12 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-09-03 01:12:19 -0500

funash gravatar image

Hi, On fedora-19 there has been some changes to cups ,

As per the above link added to cups-browsed daemon (cups-filters-1.0.30) , So check if cups-browsed daemon is running, If running try stopping and check if it's resolves the issue.

Regards Niranjan

edit flag offensive delete link more


cups-browsed is not running, so that isn't the problem.

nkstanton1 gravatar imagenkstanton1 ( 2013-09-18 12:50:00 -0500 )edit

answered 2013-09-05 06:51:04 -0500

marcindulak gravatar image

A workaround for Fedora (19) is to stop avahi (see

systemctl stop avahi-daemon.service
systemctl disable avahi-daemon.service

Setting "Browsing Off" in /etc/cups/cupsd.conf and systemctl restart cups.service does not work anymore (with cups-browsed.service stopped).

edit flag offensive delete link more


Stopping the avahi-daemon means evince doesn't list the additional printers. However, I could no longer print to the printers I had configured. So I restarted the avahi-daemon.

nkstanton1 gravatar imagenkstanton1 ( 2013-09-17 13:40:23 -0500 )edit

Question Tools

1 follower


Asked: 2013-09-02 12:24:30 -0500

Seen: 822 times

Last updated: Sep 05 '13