Ask Your Question

F19 UEFI install hangs at "Secure Boot Not Enabled"

asked 2013-08-29 19:11:42 -0500

darkphader gravatar image

updated 2013-08-30 08:35:58 -0500

Cannot get past the "Secure Boot Not Enabled" message when attempting to install (or start up a shell via troubleshooting). Hardware is a Dell PowerEdge R320. Problem occurs for both for the Live and netinstall USB images.


Debian Wheezy has no problems installing in UEFI mode.

Also if I install Fedora in BIOS boot mode it will not let me GPT partition the drive - it will repartition the drive DOS style. Nor will it let me use existing GPT partitions that I've set up.

Is there a way out of this nightmare?

edit retag flag offensive close merge delete


You're missing the point Dan and I know that Fedora 19 will install in "DOS" mode (I've done it) - But I want to install Fedora in UEFI mode and want all of my disks GPT partitioned. I can do this with other OS's but apparently not with Fedora as the installation hangs when booting via UEFI.

darkphader gravatar imagedarkphader ( 2013-08-30 11:14:31 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted

answered 2013-08-30 09:39:44 -0500

Dan Schnau gravatar image

I had this problem with my ASUS Zenbook Prime. I had to go into the BIOS and disable UEFI boot mode.

I don't have your hardware so I can't verify exactly how easy it is on a Dell PowerEdge, but usually you can boot into the BIOS options by holding down ESC or some F-key on power-up. From the looks of this manual, you can disable the UEFI boot setting. Disable that then try again.

manualslib DOT com/manual/486845/Dell-Poweredge-R320.html?page=26#manual

(sorry about the weird link - don't have enough points to post real links.)

edit flag offensive delete link more


You mean simply pasting full links (so they look like text) does not work for new users?

marcindulak gravatar imagemarcindulak ( 2013-08-30 10:30:00 -0500 )edit

Not until you get a few points. Its just to prevent spam.

Dan Schnau gravatar imageDan Schnau ( 2013-08-30 11:00:06 -0500 )edit

That prevention must have been fixed recently. In my first answer ( i was able to paste a link (of course i tried that despite the warning that i'm not allowed to do so)

marcindulak gravatar imagemarcindulak ( 2013-08-30 11:12:24 -0500 )edit

Weird. I did try posting the link before modifying it as it is, and I wasn't able to.

Dan Schnau gravatar imageDan Schnau ( 2013-08-30 11:43:13 -0500 )edit

answered 2013-10-29 11:30:29 -0500

vbraun gravatar image

You are not alone, this is

edit flag offensive delete link more

Question Tools

1 follower


Asked: 2013-08-29 19:11:42 -0500

Seen: 2,629 times

Last updated: Oct 29 '13