Ask Your Question
1

What is the gnokii --smsreader path in fedora?

asked 2013-08-23 18:28:39 -0500

yn1v gravatar image

I have a usb3g modem (ZTE MF636 HSUPA USB MODEM). I have a prepaid plan, so I have to send a sms to activate my internet connection. I wait for a reply about how much time I will activate. I send a new message with my choice. Then I got one message for confirming my request and another to tell me that the the connection was activated.

So I configured gnokii to send de message. The /dev/ttyUSB2 port is in dialout group, so I joined that group. I have permissions to use that port without having to make any changes every time the modem is plugged in.

Here is my gonkii config file:

[global]
port = /dev/ttyUSB2
model = AT
connection = serial

And there is the response from system:

$ gnokii --identify
GNOKII Version 0.6.31
IMEI         : 3x2x4x0x9x2x6x1 # changed some numbers by x
Manufacturer : ZTE INCORPORATED
No flags section in the config file.
Model        : MF636
Product name : MF636
Revision     : BD_LATMOVP673M2V1.0

I am able to send messages without any problem.

Where am I stuck is about receiving messages. I enter into sms reading mode, the Gnokii wiki said about wrting those to a file but I do not know where. Or if it is working at all

Gnokii wiki said about /tmp/sms there was no such path. As it was not created by gnokii after several tries, I created that. No luck either.

I searched the hard drive for any sms file or directory and found /usr/share/locale/sms/LC_MESSAGES There was nothing there.

I have tried to send my messages blindly, and it worked. But there are two bad scenarios. One is that the response take long time (It happens), so I will not know for sure when is ready. Worst case, I got an error response.

I have tried gnome-phone-manager. Fedora 19 does not create a launcher for it. I tried to run from terminal, and it hangs with some message about the bluetooth. I have no bluetooth on my computer.

$ gnome-phone-manager 

(gnome-phone-manager:2387): Bluetooth-CRITICAL **: bluetooth_chooser_button_set_property: assertion `str == NULL || bluetooth_verify_address (str)' failed
** Message: New connection device is empty (not changed)
** Message: New connection device is empty (not changed)
** Message: No device!
** Message: Exiting connect thread

I tried the gnome-phone-manager --config /dev/ttyUSB2 It complained about the config file not having flags

I changed the config file to:

[global]
port = /dev/ttyUSB2
model = AT
connection = serial
[flags]
MF636=MF636, SMS

The response was exactly the same:

$ gnome-phone-manager --config /dev/ttyUSB2
No flags section in the config file.
** Message: Model Unknown using default driver
Configuration file written in the current directory
Move gnokiirc to ~/.gnokiirc to start debugging with gnokii

Not sure what means "Move gnokiirc to ~/.gnokiirc" means as my config file is already at "~/.gnokiirc".

In any case logfiles were the same as above as each terminal output with --config option or without.

I tried also with gnome-phone-manager-telepathy configuring it at empathy. I can not send messages, I typed the number but the sms box never ... (more)

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-08-28 22:12:30 -0500

yn1v gravatar image

Thanks for pointing to the right page of gnokii wiki related sms.

I played a little bit before getting on track.

gnokii --showfolderstatus

This shows types of memory in use and how many messages are stored, important to get the start and end sms memory location used. For my case I had 21 sms stored on the device. I used

gnokii --getsms SM 0 20 -f sms.txt

As usual linux start with 0 as the first sms stored.

Thanks.

edit flag offensive delete link more
3

answered 2013-08-28 13:33:36 -0500

spot gravatar image

Are you using the right syntax for gnokii to receive sms?

The gnokii wiki lists the various options for the "--getsms" option (to pull them from the modem's memory), and lets you specify the output file with -f. If you don't specify an output file, they should go to stdout.

The --smsreader option may not be supported for that device. The gnokii code has "/tmp/sms" hardcoded as the top-level output directory for that option:

const char *smsdir = "/tmp/sms";

The output files should look like:

mail_*_*

or

sms_*_*_*
edit flag offensive delete link more

Comments

After some more testing, I think that the device is not supported for the --smsreader option.

yn1v gravatar imageyn1v ( 2013-09-02 12:34:26 -0500 )edit

Question Tools

Stats

Asked: 2013-08-23 18:28:39 -0500

Seen: 894 times

Last updated: Aug 28 '13