Ask Your Question
1

XFCE 4.10 and trouble changing sound volume

asked 2013-08-23 11:23:30 -0500

chickenfish gravatar image

updated 2013-08-23 21:02:47 -0500

FranciscoD_ gravatar image

So here's the deal. Whenever I change volume with either hotkeys (XF86Audio*) or mouse wheel, the volume steps differ. Alot. Say I'm at 0%. I press volume up once, and it goes up by some 40%, however next time it goes up by 30%, and so and so.

When I open xfce4-mixer (alsa mixer) I can clearly see sound card HDA Intel PCH selected, and the master volume bar behaving the way I described.

But when I open the pulse audio mixer and go to output devices, it adds 10% each step, the way it should. But the volume is clearly not defined by the pulse audio and it still goes extremely loud by just pressing it once.

The only way to properly change volume is by dragging the bar in alsa mixer.

I honestly don't really know what's happening, what to do, or how to change it. My guess would be to make pulse audio my primary sound control?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted
0

answered 2013-08-25 04:35:23 -0500

chickenfish gravatar image

After some tinkering I found the actual solution.

XFCE - Settings - Settings Editor - xfce4-mixer

And changing active cards to

PlaybackBuiltinAudioAnalogStereoPulseAudioMixer
edit flag offensive delete link more
1

answered 2013-08-24 03:29:27 -0500

zoltanh721 gravatar image

First of it, you have to use pulse audio control within XFCE as you adding the mixer control to the panel. That app gives you fine control, and you don't need extra alsa modules, or mixers. Sometimes my friends are using volumeicon as mixer, just this app hasn't received any fix or update, and crashing with Pulse randomly. Else, you have to tell us what kind of audiochip you have, because - earlier in my another laptop had an Intel HDA just with Azalia chip that runs with different IRQ's. That can be fixed easily with a conf file, and you won't loose any hair after it. :)

HTH, please provide more information as attachment.

edit flag offensive delete link more

Comments

Well, it's just that XFCE comes with both alsa and pulse mixers. I'm using PNMixer in my tray, but changing the sound with that works as described above, in fact changing the sound with anything related to pulse works weirdly. Anyhow, how do I find out what audio chip do I have? Thank you

chickenfish gravatar imagechickenfish ( 2013-08-24 03:54:41 -0500 )edit

Not every time works, and your problem depends also from the version of the alsa and kernel modules too. But the chip name can be retirieved from lspci -vv. Be careful, and maximize the terminal window, it will be VERY detailed. If you have USB soundcard, well that will be more interesting, as you have maybe an integrated on board and a stick... For USB - you have to use the lsusb -vv command. I don't know what you have added already to your install, eg. different alsa parts as you wanted to work your sound - but I need this info too.

zoltanh721 gravatar imagezoltanh721 ( 2013-08-24 04:09:51 -0500 )edit

I hope this is it: http://ur1.ca/f6ygv I'm on a laptop with an integrated soundcard by the way.

chickenfish gravatar imagechickenfish ( 2013-08-24 04:18:35 -0500 )edit

And I don't think I added anything really. This is how it behaves since fresh installation.

chickenfish gravatar imagechickenfish ( 2013-08-24 04:21:12 -0500 )edit

Great, this is it. You have Intel C200 audio chip rev4. The key here at this chip is the revision number. Other HPs and T410 Lenovo's has rev05. That's why is important to begin with this. Next you have to give me alsa-info command output. This will upload tons of alsa info and please provide the red colored link that drops. That will help me get closer.

zoltanh721 gravatar imagezoltanh721 ( 2013-08-24 04:24:38 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2013-08-23 11:23:30 -0500

Seen: 3,155 times

Last updated: Aug 25 '13