Ask Your Question
2

SDHC card reader not working

asked 2013-08-21 15:12:27 -0500

frsepulv gravatar image

updated 2013-08-21 22:43:21 -0500

FranciscoD_ gravatar image

It is pretty much the same problem posted here under the name "Fedora 19 SD Card not recognized" (I'm sorry I can't post links yet). Basically my F18 installation doesn't recognize my SD card reader, even though I installed kmod-staging. In that question the answer suggest to update the kernel, although that didn't help in my case - I'm currently using version 3.10.7-100.fc18.x86_64 (I downgraded from F19 because I believed it might fix this issue, among other reasons). My problem comes from this error message:

# modprobe rts5139
modprobe: ERROR: could not insert 'rts5139': Required key not available

That, unlike what seems to be suggested in the answer to the question I link above, doesn't go away when updating to the latest kernel.

Here's lsusb output:

$ lsusb
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 003 Device 002: ID 5986:029d Acer, Inc 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 046d:c52e Logitech, Inc. 
Bus 001 Device 004: ID 8087:07da Intel Corp. 
Bus 001 Device 005: ID 0bda:0129 Realtek Semiconductor Corp. RTS5129 Card Reader Controller

And I'm running a Lenovo Z400 (non-touchscreen) with F18 in UEFI boot mode with SecureBoot.

Any help would be greatly appreciated, I'm starting to run out of things to try (short of manually compiling a kernel, as some CentOS-related threads I found through Google suggest when dealing with that "Required key not available" error).

edit retag flag offensive close merge delete

Comments

1

I'd a feeling that SecureBoot could be the problem here... but I really didn't want to turn it off. Guess it still requires some time to work better with Linux distros (thanks, MS? xD).

Had to turn it off since enforcemodulesig=0 didn't make it (perhaps it's just ignored when SecureBoot is on). As a side effect, now my dual boot with Windows is fixed - GRUB also has problems chainloading Windows 8 when SecureBoot is enabled, and using your BIOS settings as a boot selection menu isn't the sweetest of experiences.

Thanks a lot!

frsepulv gravatar imagefrsepulv ( 2013-08-21 18:47:45 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-08-21 16:29:26 -0500

jamielinux gravatar image

updated 2013-08-21 16:29:52 -0500

If SecureBoot is enabled, then I believe the Fedora kernel will expect all kernel modules to be signed. The key used for signing the modules in the Fedora kernel is private, so this key cannot be used for signing third-party modules like rts5139.

You have two options that may fix your problem:

  1. Disable SecureBoot altogether.
  2. Pass "enforcemodulesig=0" to the kernel command-line via GRUB.
edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-08-21 15:12:27 -0500

Seen: 3,687 times

Last updated: Aug 21 '13