Ask Your Question
2

How to disable the Terminal Beep in Fedora 19?

asked 2013-08-20 12:46:02 -0500

jochenw gravatar image

updated 2013-08-20 22:22:58 -0500

FranciscoD_ gravatar image

Hi,

I am aware that before Fedora 19 we used to disable the terminal beep by removing/blacklisting the pcspr module. However, this solution wouldn't work for me, as the pcspr module isn't in the module list, and my machine is beeping anyways:

jwi@mcjwi01 workspace]$ lsmod | grep pcspkr
[jwi@mcjwi01 workspace]$

I also know, that I can disable the beep in my profile for gnome-terminal. However, that solution isn't sufficient for me: Other programs (for example, Emacs) are beeping too. So, here's my question:

How do I disable the terminal beep in Fedora 19.

edit retag flag offensive close merge delete

Comments

If you are using Gnome-Shell, what happens if you go in the sound properties and mute the sound-effects?

hmaarrfk gravatar imagehmaarrfk ( 2013-08-20 20:54:52 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
2

answered 2013-08-20 13:19:53 -0500

baptistemm gravatar image

Hi,

http://www.debian-administration.org/articles/110 (found easily on Google) can be helpful.

edit flag offensive delete link more
0

answered 2013-12-30 08:03:18 -0500

atc gravatar image

Using the xset program worked for me:

xset b off
edit flag offensive delete link more
0

answered 2013-08-25 11:26:57 -0500

rheldaemon gravatar image

and for gnome terminal: Edit -> Profiles -> Default -> Edit / General Tab -> General -> Un-Check Terminal bell option

edit flag offensive delete link more

Question Tools

1 follower

Stats

Asked: 2013-08-20 12:46:02 -0500

Seen: 6,957 times

Last updated: Dec 30 '13