Ask Your Question
3

gdm login gone. boots into gnome as user 'gdm'

asked 2013-08-13 13:31:33 -0500

dstasinski gravatar image

updated 2013-08-13 17:25:13 -0500

FranciscoD_ gravatar image

Today I turned on my Fedora 19 desktop and instead of displaying the normal gdm login screen, it went directly into Gnome as user 'gdm' The only options are to log out or reboot. When I log out it immediately goes back into Gnome as user 'gdm'

I am absolutely lost on this. Does anyone have any suggestions?

edit retag flag offensive close merge delete

Comments

1

Thank you, that took care of it.

dstasinski gravatar imagedstasinski ( 2013-08-13 14:18:20 -0500 )edit

@dstasinski: Please mark the answer as correct and comment rather than post another answer in the future. I've marked it for you this time. If you're new to the forum, please do take a minute to glean through the guidelines and "sticky" posts from the sidebar on the main page. Thanks :)

FranciscoD_ gravatar imageFranciscoD_ ( 2013-08-13 17:30:15 -0500 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2013-08-13 13:34:02 -0500

rstrode gravatar image

This was a bug in a gdm package pushed to updates-testing. Upgrade to this package:

https://admin.fedoraproject.org/updates/gdm-3.8.4-2.fc19

to fix your problem

edit flag offensive delete link more

Comments

The update has already been pushed to stable. However, if it hasn't reached your mirrors yet, please grab the rpms from koji and update your packages manually via yum localinstall: http://koji.fedoraproject.org/koji/buildinfo?buildID=456225

FranciscoD_ gravatar imageFranciscoD_ ( 2013-08-13 19:58:08 -0500 )edit
0

answered 2013-08-13 16:21:00 -0500

patrick gravatar image

Same thing with me and I don't have the dependencies to install the new version. I went into /etc/gdm/custom.conf and turned on automatic login and made my user id auto login and at least I was able to get past it:

[daemon]

# AutomaticLoginEnable=False
# AutomaticLogin=
AutomaticLoginEnable=True
AutomaticLogin=patrick

The bug says it's approved for stable updates so I'll wait for it instead of downgrading since I have a workaround.

edit flag offensive delete link more

Comments

There aren't any deps. You just need to grab the gdm and gdm-libs package from the koji build as I've commented above. I just did this, since yum update doesn't show the update yet.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-08-13 19:59:27 -0500 )edit

Question Tools

Stats

Asked: 2013-08-13 13:31:33 -0500

Seen: 887 times

Last updated: Aug 13 '13