Ask Your Question
1

Default Applications XFCE

asked 2013-08-13 13:10:24 -0500

Here to all XFCE pros. Whenever I want open an image, the default application (who knows how was it set as default) to open images is the Wine Internet Explorer.

Doing some research in the internet I find several suggestions like the xfce4-settings-editor but I cannot find a way to specify to it which app should it open images with. The command exo-open seems to only work with 4 categories (WebBrowser, MailReader, TerminalEmulator or FileManager) so doing something like

$ exo-open --launch ristretto image.jpg

would be completely useless and lame.

I know there are some other ways to fix it, like uninstalling the Wine Internet Explorer or Wine, or just right-click the image and select the program I want to open it with. But I'd really want to know how to fix it without uninstalling wine and without right-clicking the image everytime I want to open it.

Thanks beforehand.

edit retag flag offensive close merge delete

Comments

Right click on the icon in Thunar > Properties> General tab > Open With doesn't work?

skytux gravatar imageskytux ( 2013-08-13 13:35:02 -0500 )edit

@skytux I want to go to the root of the problem.

dnlsrl gravatar imagednlsrl ( 2013-08-13 13:47:17 -0500 )edit

And...? I don't understand you. You don't need to right click every time you want to open your file, because with the method I described above, it will open with de same application you have set the first time. Do you understand?

skytux gravatar imageskytux ( 2013-08-13 13:57:47 -0500 )edit

@skytux I understand, I'm sorry. I use nautilus, and I tried what you said before. Even though I could have open Thunar and fix the problem, I wasn't looking for an straightforward answer. I wanted to understand the root of the problem and, as you can see in the answer, I found it. Thanks for your help!

dnlsrl gravatar imagednlsrl ( 2013-08-13 14:08:52 -0500 )edit

2 Answers

Sort by » oldest newest most voted
3

answered 2013-08-13 14:13:32 -0500

hroncok gravatar image

Open MIME Type Editor from Settings in Application menu. Type image into the Filter field. In column Default application, you can change your images default apps to Ristretto, or any other app.

edit flag offensive delete link more

Comments

Dude! I guess this is better than the answer I posted myself. I should have seen that app in the settings menu DUH! Silly me. Thank you!

dnlsrl gravatar imagednlsrl ( 2013-08-13 14:25:09 -0500 )edit
0

answered 2013-08-13 14:04:08 -0500

So I found the fixing of my problem myself. There are these files in the ~/.local/share/applications/ directory called mimeapps.list and mimeinfo.cache.

While mimeapps.list was assigning the correct application for the jpeg, png, gif types, mimeinfo.cache (which I suspect Wine for creating it) assigned the same extensions to its Internet Explorer. So I removed those lines. I could as well delete the whole file. Right after that, I tried opening an image and voilà! Ristretto Image Viewer, the one which is supposed to be the default, opened the image.

edit flag offensive delete link more

Comments

Well, I know all that also. But as you said Xfce, I associated it to Thunar, not Nautilus (even though, it is in the same way as with Tunar). On the other hand, I didn't know that by "I want to go to the root of the problem" you really meant "I want to fix my problem through command line only". You need to be more specific :). Good luck!

skytux gravatar imageskytux ( 2013-08-13 14:25:25 -0500 )edit

Not specifically the command line. Just to know why the heck did wine assigned the image viewer itself and how to take it back to its original setting. Dude, you should have seen how pissed I was about it xD

dnlsrl gravatar imagednlsrl ( 2013-08-13 14:29:53 -0500 )edit
1

Well, you still have to figure it out haha... but at least you fixed it... Saludos!! :)

skytux gravatar imageskytux ( 2013-08-13 14:39:41 -0500 )edit

Question Tools

Stats

Asked: 2013-08-13 13:10:24 -0500

Seen: 4,943 times

Last updated: Aug 13 '13