Ask Your Question

Fedora 19 Dota2 and SeLinux Problem

asked 2013-08-11 15:25:38 -0500

LoneDruid gravatar image

I'm trying to run Dota2 with bumblebee. But I keep getting this error.

SELinux is preventing /home/omer/.local/share/Steam/SteamApps/common/dota 2 beta/dota_linux from using the execheap access on a process.

Plugin: catchall 
you want to allow dota_linux to have execheap access on the processIf you believe that dota_linux should be allowed execheap access on processes labeled unconfined_t by default.
You should report this as a bug.
You can generate a local policy module to allow this access.
Allow this access for now by executing:
# grep dota_linux /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

I give the command "grep dota_linux /var/log/audit/audit.log | audit2allow -M mypol" then i get this error

bash: audit2allow: command not found..

I can play Dota2 on Ubuntu 13.04 without any problems.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-08-12 02:45:41 -0500

marcindulak gravatar image

updated 2013-08-12 02:59:07 -0500

There are several threads about SElinux/stem problems on the net. If you look at the full SElinux report and search forums you can find the following advice (

   setsebool -P selinuxuser_execheap 1

or changing SELINUX from enforcing into permissive in /etc/selinux/config + reboot Having SElinux non-enforcing results in lowering security of your system, but it may be necessary when using software that is not designed to work with SElinux. See the issue open here and a long discussion here

You could also try to go (a possibly long) way you started, and generate a local policy. The missing audit2allow is available in:

   yum install policycoreutils-devel
edit flag offensive delete link more

Question Tools

1 follower


Asked: 2013-08-11 15:25:38 -0500

Seen: 2,618 times

Last updated: Aug 12 '13