Ask Your Question
0

Glc video capturing & playing software

asked 2013-08-10 15:46:45 -0500

anishjp gravatar image

updated 2014-09-29 00:31:11 -0500

mether gravatar image

Has anyone successfully installed glc in F18? I get this error when I try to install it from its source file

[root@desktop Downloads]# ./glc-build.sh
info  : Welcome to glc install script!
error : Missing X11 headers (Ubuntu users: sudo apt-get install libx11-dev)

What package provides this X11 headers?

edit retag flag offensive close merge delete

Comments

Did you try shift+ctrl+alt+r to take screencast?

yanglifu90 gravatar imageyanglifu90 ( 2013-08-10 20:29:25 -0500 )edit

He doesn't need a screencast. The error he posted is quite enough. @anishjp, it is a really really bad idea to build stuff as root. It may change system files and you'll find these changes very very difficult to undo. If you must, please build as a non root user.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-08-10 21:24:52 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-08-10 21:22:39 -0500

FranciscoD_ gravatar image

Are none of these packages the "glc" package that you're looking for?

[asinha@localhost  ~]$ sudo yum search glc
<snip>
=========================================================================== N/S matched: glc ===========================================================================
GLC_Player.x86_64 : GLC_Player is an Open Source software used to view 3d models (OBJ Format)
GLC_lib-devel.i686 : Development files for GLC_lib
GLC_lib-devel.x86_64 : Development files for GLC_lib
quesoglc-devel.i686 : Development files for quesoglc
quesoglc-devel.x86_64 : Development files for quesoglc
GLC_lib.i686 : C++ class library for OpenGL application based on Qt 4
GLC_lib.x86_64 : C++ class library for OpenGL application based on Qt 4
perl-Wx-GLCanvas.x86_64 : Interface to wxWidgets' OpenGL canvas
quesoglc.i686 : The OpenGL Character Renderer
quesoglc.x86_64 : The OpenGL Character Renderer

  Name and summary matches only, use "search all" for everything.
[asinha@localhost  ~]$

These are all the X11 devel packages in the repositories I think:

[asinha@localhost  ~]$ sudo yum list xorg*devel
<snip>
Installed Packages
xorg-x11-proto-devel.noarch                                                7.7-4.fc19                                                          @fedora
Available Packages
xorg-x11-drv-catalyst-devel.i686                                           13.8-0.1.beta1.fc19                                                 rpmfusion-nonfree-updates
xorg-x11-drv-catalyst-devel.x86_64                                         13.8-0.1.beta1.fc19                                                 rpmfusion-nonfree-updates
xorg-x11-drv-evdev-devel.i686                                              2.8.1-2.fc19                                                        updates
xorg-x11-drv-evdev-devel.x86_64                                            2.8.1-2.fc19                                                        updates
xorg-x11-drv-intel-devel.i686                                              2.21.12-2.fc19                                                      updates
xorg-x11-drv-intel-devel.x86_64                                            2.21.12-2.fc19                                                      updates
xorg-x11-drv-mouse-devel.i686                                              1.9.0-1.fc19                                                        fedora
xorg-x11-drv-mouse-devel.x86_64                                            1.9.0-1.fc19                                                        fedora
xorg-x11-drv-nvidia-173xx-devel.i686                                       173.14.37-5.fc19                                                    rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-173xx-devel.x86_64                                     173.14.37-5.fc19                                                    rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-304xx-devel.i686                                       304.88-12.fc19                                                      rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-304xx-devel.x86_64                                     304.88-12.fc19                                                      rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-devel.i686                                             1:319.32-7.fc19                                                     rpmfusion-nonfree-updates
xorg-x11-drv-nvidia-devel.x86_64                                           1:319.32-7.fc19                                                     rpmfusion-nonfree-updates
xorg-x11-drv-openchrome-devel.i686                                         0.3.3-1.fc19                                                        fedora
xorg-x11-drv-openchrome-devel.x86_64                                       0.3.3-1.fc19                                                        fedora
xorg-x11-drv-synaptics-devel.i686                                          1.7.1-4.fc19                                                        updates
xorg-x11-drv-synaptics-devel.x86_64                                        1.7.1-4.fc19                                                        updates
xorg-x11-drv-wacom-devel.i686                                              0.22.0-2.fc19                                                       updates
xorg-x11-drv-wacom-devel.x86_64                                            0.22.0-2.fc19                                                       updates
xorg-x11-glamor-devel.i686                                                 0.5.0-5.20130401git81aadb8.fc19                                     fedora
xorg-x11-glamor-devel.x86_64                                               0.5.0-5.20130401git81aadb8.fc19                                     fedora
xorg-x11-server-devel.i686                                                 1.14.2-9.fc19                                                       updates
xorg-x11-server-devel.x86_64                                               1.14.2-9.fc19                                                       updates
xorg-x11-xkb-utils-devel.i686                                              7.7-7.fc19                                                          fedora
xorg-x11-xkb-utils-devel.x86_64                                            7.7-7.fc19                                                          fedora
xorg-x11-xtrans-devel.noarch                                               1.2.7-4.fc19                                                        fedora
[asinha@localhost  ~]$

I'm pretty sure one of them is what you're looking for. Please read the glc documentation and see which one exactly it is you need.

edit flag offensive delete link more
0

answered 2013-08-19 16:29:28 -0500

anishjp gravatar image

Okay, I installed the following packages but at the end I get an error!

[anishjp@desktop Downloads]$ ./glc-build.sh
info  : Welcome to glc install script!
error : Missing X11 headers (Ubuntu users: sudo apt-get install libx11-dev)

[root@desktop ~]# yum install libXtst-devel

[anishjp@desktop Downloads]$ ./glc-build.sh
info  : Welcome to glc install script!
error : Missing XF86VidMode headers (Ubuntu users: sudo apt-get install libxxf86vm-dev)

[root@desktop ~]# yum install libXxf86vm-devel.x86_64
[anishjp@desktop Downloads]$ ./glc-build.sh
info  : Welcome to glc install script!
error : Missing OpenGL headers (Ubuntu users: sudo apt-get install libgl1-mesa-dev)

[root@desktop ~]# yum install mesa-libGL-devel.x86_64
[anishjp@desktop Downloads]$ ./glc-build.sh
info  : Welcome to glc install script!
error : Missing ALSA headers (Ubuntu users: sudo apt-get install libasound2-dev)

[root@desktop ~]# yum install alsa-lib-devel

[anishjp@desktop Downloads]$ ./glc-build.sh
info  : Welcome to glc install script!
error : Missing libpng headers (Ubuntu users: sudo apt-get install libpng12-dev)

[root@desktop ~]# yum install libpng-devel.x86_64
[anishjp@desktop Downloads]$ ./glc-build.sh
info  : Welcome to glc install script!
error : CMake not installed (Ubuntu users: sudo apt-get install cmake)

[root@desktop ~]# yum install cmake.x86_64
[anishjp@desktop Downloads]$ ./glc-build.sh
info  : Welcome to glc install script!
error : Can't compile 32-bit code (Ubuntu users: sudo apt-get install gcc-multilib)

[root@desktop ~]# yum install glibc-devel.i686

[anishjp@desktop Downloads]$ ./glc-build.sh
info  : Welcome to glc install script!
        Enter path where glc will be installed.
          (leave blank to install to root directory)
      > 
        Enter compiler optimizations.
          (-O2 -msse -mmmx -fomit-frame-pointer)
      > 
        Use git (y/n)
          (git contains latest unstable development version)
      > n
info  : Fetching sources...
**error : Can't fetch elfhacks**

How do I fetch this elfhacks?

edit flag offensive delete link more

Comments

Sorry but it is a old program, some dependencies not exist... WTF 6 years old! is a joke!. Exist best options... check the year! https://github.com/nullkey/glc , other alternatives: https://ask.fedoraproject.org/question/10272/how-can-i-capture-a-video-of-my-screen-in-fedora/

davidva gravatar imagedavidva ( 2013-08-19 19:03:49 -0500 )edit

Well Ctrl+shift+Alt+r works. I hope I can record my sound as well along with the video!

anishjp gravatar imageanishjp ( 2013-08-20 13:01:33 -0500 )edit

Question Tools

Stats

Asked: 2013-08-10 15:46:45 -0500

Seen: 587 times

Last updated: Aug 19 '13