Ask Your Question
1

Super+M Not Working. How can I reset to default? [Closed]

asked 2013-08-10 09:57:39 -0500

Tinker gravatar image

updated 2013-08-23 20:38:57 -0500

Hi All,

After booting up today whenever I press the Super+M shortcut instead of getting the notification window it minimises the open windows. I have gone into the shortcut settings but it does not look like that anything has changed, and I did try resetting to Super+M just to make sure but no help. Is there a way to reset the shortcuts as I can not see an option in the settings->keyboard? Using Fedora 19.

Note that in Overview the Super+M works to show the notifications, but outside of overview it minimizes instead. Assigning Super+M to another keybinding like CTRL+M works fine too and that is what I am using as a workaround for now.

Extra Info:

For reference this is the output of gsettings list-recursively org.gnome.desktop.wm.keybindings | egrep -i "super"

org.gnome.desktop.wm.keybindings maximize ['<super>Up'] org.gnome.desktop.wm.keybindings minimize ['<super>h'] org.gnome.desktop.wm.keybindings move-to-workspace-down ['<super><shift>Page_Down', '<control><shift><alt>Down'] org.gnome.desktop.wm.keybindings move-to-workspace-up ['<super><shift>Page_Up', '<control><shift><alt>Up'] org.gnome.desktop.wm.keybindings switch-applications ['<super>Tab', '<alt>Tab'] org.gnome.desktop.wm.keybindings switch-group ['<super>Above_Tab', '<alt>Above_Tab'] org.gnome.desktop.wm.keybindings switch-input-source ['<super>space'] org.gnome.desktop.wm.keybindings switch-to-workspace-down ['<super>Page_Down', '<control><alt>Down'] org.gnome.desktop.wm.keybindings switch-to-workspace-up ['<super>Page_Up', '<control><alt>Up'] org.gnome.desktop.wm.keybindings unmaximize ['<super>Down', '<alt>F5']

Thanks!

edit retag flag offensive close merge delete

Comments

It should work everywhere (in GNOME), unless a specific application is handling it itself. I don’t know what could be wrong though.

Gareth Jones gravatar imageGareth Jones ( 2013-08-10 13:10:35 -0500 )edit

Tried Halfline's suggestion but the terminal command did not change anything.

Tinker gravatar imageTinker ( 2013-08-10 17:53:06 -0500 )edit

Can you create a new user and see if it works there? It'll give us a better idea of where the problem may be.

FranciscoD_ gravatar imageFranciscoD_ ( 2013-08-10 20:30:51 -0500 )edit

Logged into another users account on this computer and Super+M works fine. Looks like it is limited to just my account.

Tinker gravatar imageTinker ( 2013-08-10 22:47:43 -0500 )edit

A brute force solution might be to move GNOME Shell-related directories in ~/.config out of the way, e.g. ~/.config/dconf, but that will also reset most other GNOME settings to their defaults. Obviously it’d be better to identify the specific option that causes the problem though.

Gareth Jones gravatar imageGareth Jones ( 2013-08-11 09:58:53 -0500 )edit

3 Answers

Sort by » oldest newest most voted
2

answered 2013-08-10 17:26:49 -0500

rstrode gravatar image

from a terminal try running (as your user, not root):

$ gsettings reset org.gnome.desktop.wm.keybindings minimize

edit flag offensive delete link more

Comments

Does not work

Tinker gravatar imageTinker ( 2013-08-14 09:56:39 -0500 )edit
0

answered 2013-08-17 00:21:36 -0500

Tinker gravatar image

FINALLY!

It is the Shellshape Gnome Extension causing this issue. I am not even sure why as I can not even see a reference to Super+M in the dconf settings. Either way, turning off this extension allows me to use Super+M again.

Thanks all for the time and effort.

edit flag offensive delete link more
0

answered 2013-10-20 19:09:29 -0500

sciurus gravatar image

In org.gnome.shell.extensions.net.gfxmonk.shellshape.keybindings there is a minimize-window setting which defaults to <Mod>4m I deleted this value with dconf-editor and using Super+M to raise the message tray started working.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-08-10 09:57:39 -0500

Seen: 1,313 times

Last updated: Oct 20 '13