Ask Your Question
0

A problem in installing SPE, python editor.

asked 2013-08-06 01:29:42 -0500

sina gravatar image

updated 2013-08-06 07:08:29 -0500

FranciscoD_ gravatar image

When I want to install SPE by command line I get this error.

Error: Package: tkinter-2.7.5-1.fc19.i686 (fedora)
       Requires: python = 2.7.5-1.fc19
       Installed: python-2.7.5-3.fc19.i686 (@updates)
           python = 2.7.5-3.fc19
       Available: python-2.7.5-1.fc19.i686 (fedora)
           python = 2.7.5-1.fc19
You could try using --skip-broken to work around the problem
You could try running: rpm -Va --nofiles --nodigest

How can I make it right to install?

edit retag flag offensive close merge delete

Comments

2

Have you disabled fedora-updates.repo? What is the output of: yum clean all && yum repolist && yum info tkinter

marcindulak gravatar imagemarcindulak ( 2013-08-06 06:11:52 -0500 )edit

You're right. I once edited su -c 'gedit /etc/yum.repos.d/fedora-updates.repo' and changed the enable value to 0 :( I changed to 1 and everything is OK now. please Answer this question from Answer panel to change it as solved.

sina gravatar imagesina ( 2013-08-06 10:27:28 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-08-06 10:53:50 -0500

marcindulak gravatar image

Making sure the Fedora "updates" repository is enabled (enabled=1 in /etc/yum.repos.d/fedora-updates.repo) solved the problem.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-08-06 01:29:42 -0500

Seen: 766 times

Last updated: Aug 06 '13