Ask Your Question

Keyboard and mouse unavailable in X

asked 2013-07-31 18:49:55 -0500

sideburns gravatar image

updated 2013-07-31 21:14:16 -0500

I just "upgraded" my desktop from F17 to F19. It didn't complete, and I had over 1,000 duplicate packages to clean up. And, I could only do that from a CLI (and did) because when lightdm starts, the mouse and keyboard stop responding. I can log in and use startxfce4, but as soon as it comes up, the same thing happens. Looking through /var/log/Xorg.0.log, using ssh from my laptop, I found this:

[ 41.590] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled. [ 41.590] (WW) Disabling Mouse0 [ 41.590] (WW) Disabling Keyboard0

I have no idea what's causing this, and checking through the file, this is the only reference to Hotplugging. I've tried using the Magic SysRq Key ( but it doesn't bring back the keyboard or mouse, although I can use it to reboot or kill X. (That leaves me with a blank screen, a block mouse cursor and no sign that anything I type is accepted.) Does anybody have any idea where to look or how to fix this? A clean install is not an option, so don't suggest it.

Following a suggestion from a mailing list, I removed all references to either mouse of keyboard from /etc/X11/xorg.conf (keeping a backup) and tried again. No better, but now I see this in Xorg.0.log:

[ 306.954] (II) The server relies on udev to provide the list of input devices. If no devices become available, reconfigure udev or disable AutoAddDevices.

Is udev the issue? If so, what can I do?

edit retag flag offensive close merge delete

2 Answers

Sort by ยป oldest newest most voted

answered 2013-08-01 03:20:58 -0500

sideburns gravatar image

I've found and fixed it. Looking through an old Xorg log, from before the upgrade, I found references to evdev. Using yum, I found xorg-x11-drv-evdev.i686, installed it and commented out that section you suggested. Now working!

edit flag offensive delete link more


Yup that did it for me. History: upgraded from FC20 to FC21. Keyboard, mouse stop working in X yum install xorg-x11-drv-evdev and everything is fine.

zmanish gravatar imagezmanish ( 2018-06-22 05:12:19 -0500 )edit

answered 2013-08-01 00:59:00 -0500

jamielinux gravatar image

updated 2013-08-01 02:15:31 -0500

Can you paste a copy of the Xorg.conf you're using to Perhaps also try without a Xorg.conf at all. And perhaps fpaste the output of yum list installed xorg\*

Finally, try adding this to your Xorg.conf:

Section "ServerFlags"
  Option "AllowEmptyInput" "False"
  Option "AutoAddDevices" "False"
edit flag offensive delete link more


The current xorg.config is the default one created by nVidia, with only one section, to identify the nvidia driver for the screen. You didn't say where to put those two options, but putting them down at the bottom, outside any section didn't work: X rejected both of them as not valid in that location. However, thanx for your answer. I'll try it now with no config file.

sideburns gravatar imagesideburns ( 2013-08-01 01:42:55 -0500 )edit

Sorry, been years since I've even had a Xorg.conf on any system. I think it needs to go inside a ServerFlags section. I'll update my post above.

jamielinux gravatar imagejamielinux ( 2013-08-01 02:15:05 -0500 )edit

Question Tools


Asked: 2013-07-31 18:49:55 -0500

Seen: 6,221 times

Last updated: Aug 01 '13