Ask Your Question
0

Gnome won't start after installing catalyst drivers(Fedora 19)

asked 2013-07-28 05:58:07 -0500

tusharkant gravatar image

Well the title describes it all. I recently installed fedora 19 on my AMD A10 6800K system with Radeon HD 8670. I have rpmfusion enabled on my system and installed the akmod-catalyst driver which all goes smooth and dandy but after a reboot gnome gives a fullscreen error saying something went wrong and the only option provided is logout. Which if you press the system goes completely blank and the only way to reboot/poweroff is to switch to another virtual console and use the commandline there.

Anyone know a fix. The only one I've found is to uninstall catalyst drivers completely and switch back to the opensource drivers but that's not a very good option as most of my steam games don't work well or worst some don't even start.

edit retag flag offensive close merge delete

7 Answers

Sort by » oldest newest most voted
0

answered 2013-08-10 17:35:11 -0500

rstrode gravatar image

One thing you can do to get your desktop back (not a permanent solution by any means) is turn off hardware acceleration and force software fallback. to do that put

LIBGL_AWAYS_SOFTWARE=y

in the /etc/environment file.

edit flag offensive delete link more
0

answered 2013-08-22 02:15:39 -0500

Onuonga gravatar image

updated 2013-08-22 02:16:20 -0500

there might be something else. If you check your boot messages.. this is the place where it usually says ok all the way through. check if there is an error there. it might be that installls are correct but some module is not loading properly

edit flag offensive delete link more
0

answered 2013-07-30 22:47:05 -0500

battlecheeze gravatar image

updated 2013-08-01 08:42:11 -0500

Did you update to the latest kernel? 3.10.3-300 ? They don't have yet the kmod-catalyst for the 3.10.3-300. if you have the 3.9.9.302 or the previous kernel, use that.

edit flag offensive delete link more

Comments

I switched to debian for the time being till the 13.6 driver gets stable...but as far as I remember in was the 3.10 kernel...

tusharkant gravatar imagetusharkant ( 2013-08-01 02:21:31 -0500 )edit

let's wait for the kmod catalyst 3.10.3-300 to arrive :-).

battlecheeze gravatar imagebattlecheeze ( 2013-08-01 08:44:26 -0500 )edit

I have the same problem with an AMD Radeon HD 7770, and downgrading a kernel did not fix the problem.

Elad Alfassa gravatar imageElad Alfassa ( 2013-08-04 11:15:00 -0500 )edit

i couldn't post a comment in your answer cyril maybe you could see this. http://blogs.dailynews.com/click/2013/07/30/problem-packaged-proprietary-amd-catalyst-video-driver-linux/ and also this applies to 13.4 and 13.6 https://bugzilla.redhat.com/show_bug.cgi?format=multiple&id=991112

battlecheeze gravatar imagebattlecheeze ( 2013-08-07 23:52:06 -0500 )edit
0

answered 2013-08-07 04:32:48 -0500

filrouge gravatar image

updated 2013-08-07 04:34:39 -0500

Hi battlecheeze,

Where do you find your informations about the dysfunction between the kmod-catalyst-13.8-0.1.beta1.fc19.x86_64 package and the 3.10 kernel. I haven't found an official announcement about that. Could you share an URL or a log which brings the informations. Because when I go on the AMD website I read the 3.10 is supported.

Best regards, Cyril

edit flag offensive delete link more
0

answered 2013-09-21 15:12:43 -0500

tusharkant gravatar image

After struggling with this problem for like a century....Here is the perfect solution.

First remove all catalyst packages

yum remove catalyst* akmod-catalyst* kmod-catalyst*

After the kernel 3.11 update go to your /etc/default/grub file and add radeon.dpm=1 to the GRUB_CMDLINE_LINUX variable, it should look something like this:

GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 vconsole.keymap=us $([ -x /usr/sbin/rhcrashkernel-param ] && /usr/sbin/rhcrashkernel-param || :) rd.luks=0 vconsole.font=latarcyrheb-sun16 rhgb quiet radeon.dpm=1"

Then run as root

grub2-mkconfig -o /boot/grub/grub.cfg

For EFI systems

grub2-mkconfig -o /boot/efi/EFI/fedora/grub.cfg

You may add the following lines in your /etc/environment file

R600_DEBUG=sb

CLUTTER_VBLANK=none

This gives me the best performance I have ever gotten out of my APU, even better than the catalyst drivers. The frame rates are identical to catalyst, absolutely no tearing, fewer lags on native resolution(catalyst only handles up to 1280x720), fan makes less noise; so definitely give this a try.

One word of caution though, don't overclock your gpu when using the open source drivers. My experience with overclocking while using open source drivers has been pretty bad. Also if you play Brutal Legends then that game causes a system lockup.

edit flag offensive delete link more
0

answered 2013-08-08 00:25:15 -0500

$chmod 777 -R /proc/ati

edit flag offensive delete link more
0

answered 2013-08-08 04:00:33 -0500

Oneiroi gravatar image

This at least allowed me to get back online

  1. Remove everything catalyst yum remove "*catalyst*"
  2. reboot into 3.9 kernel
  3. install akmod-catalyst
  4. reboot one last time into 3.9 kernel ... I'm now back online hope this also fixes it for others.
edit flag offensive delete link more

Question Tools

3 followers

Stats

Asked: 2013-07-28 05:58:07 -0500

Seen: 8,998 times

Last updated: Sep 21 '13