Ask Your Question
0

set PATH after manual program install

asked 2013-07-27 10:14:24 -0500

based gravatar image

Hello! I have manually installed TexLive following instructions from their website (which I'm not allowed to post). It's a perl script that does the installation. After that, Im supposed to do

PATH=/usr/local/texlive/2013/bin/i386-linux:$PATH

but I don't understand what it does and what it's supposed to do (new to linux) I assume it's incorrect, because initially, the commands for the program (tex, pdftex etc...) worked, but only in the very same terminal I used to do the installation, not in another one. After reboot, the commands do not work. What's the problem? Greets, based.

edit retag flag offensive close merge delete

Comments

A previous install of texlive with yum didn't work. It didn't find most of the tex-packages I used in my tex documents.

However, I think there's not much left to do with my install: It works fine, when I issue the command

PATH=/usr/local/texlive/2013/bin/i386-linux:$PATH; export PATH

as root. What do I have to do to make it work without having to do this command everytime?

When I use the PATH command as a user other than root, I can use the programs, but some tex-packages are not found. How can I make them available for all other users?

based gravatar imagebased ( 2013-07-27 10:38:43 -0500 )edit

Please use comment to comment.. The problem with your "solution" is that you won't be able to easily maintain your local installation. Better would have been to give us the issues you got while installing with yum.

To export PATH for all users, create a simple tex.sh file at /etc/profile.d/tex.sh and write your line in there. It will be read for every terminal/users.

shaiton gravatar imageshaiton ( 2013-07-27 11:57:46 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
2

answered 2013-07-27 10:25:46 -0500

shaiton gravatar image

You should have install the texlive package instead, that we provide in Fedora. It's easier, safer, faster, better :)

Either using yum, packagekit or any other offical way to install software under Fedora.

To answer to your question (which is not really your need), you set your path only on your current terminal. You can see it as a local variable. The best way to deal with this sort of "issue" is by exporting your variable in your local ~/.bashrc file. Open it to know more. But it's a per user file, won't work for other accounts on your computer. You would need to write that in /etc/default...

But really, when your software is already on the Fedora repositories, install it from there.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-07-27 10:14:24 -0500

Seen: 5,000 times

Last updated: Jul 27 '13