Ask Your Question
1

Blacklist, disable, uninstall or destroy radeon module

asked 2013-07-26 09:32:55 -0500

Mkotechno gravatar image

I have a Dell laptop with both Intel and ATI GPU, I want to disable ATI and just use Intel one.

I just moved to Fedora from Ubuntu, in Ubuntu I managed to disable radeon just adding radeon.modeset=0 to grub, but in Fedora this not work anymore.

I tried:

  • Adding rdblacklist=radeon in grub.
  • Adding blacklist=radeon in grub.
  • Adding radeon.modeset=0 in grub.
  • Adding blacklist radeon to blacklist.conf
  • Adding install radeon /bin/false to blacklist.conf
  • Uninstalling xorg-x11-drv-ati package.

...And obviosly updating grub and initramfs.

But radeon module keeps loading, surely because other modules require it:

$ lsmod | grep radeon

radeon 791419 1

i2c_algo_bit 13257 2 i915,radeon

drm_kms_helper 46343 2 i915,radeon

ttm 79750 1 radeon

drm 272623 7 ttm,i915,drm_kms_helper,radeon

i2c_core 34096 7 drm,i915,i2c_i801,drm_kms_helper,i2c_algo_bit,radeon,videodev

I know I can disable the ATI card with Switcheroo but then I get weird freezes after suspend that needs to be fixed with suspend scripts that gives me more issues ad infinutum...

So, how the hell can I avoid to load the f###ing radeon module?, What package installs radeon.ko?

Please help or I will open the laptop and tear the ATI card with my own mouth.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-27 00:03:52 -0500

cleitonlima gravatar image

Hi, try to add this to the final of Kernel's line in grub.cfg:

radeon.modeset=0 rd.driver.blacklist=radeon nomodeset

or

radeon.modeset=0 rd.blacklist=radeon nomodeset

edit flag offensive delete link more

Comments

Thanks cleitonlima, but doesn't work, blacklist is ignored and with nomodeset none of GPUs are enabled. How can be so hard blacklist a single module???

Mkotechno gravatar imageMkotechno ( 2013-07-27 07:00:01 -0500 )edit

Reading more about Hybrid Graphics, I saw the solution is Switcheroo. For some reason, this kind of hardware ignore the blacklist. Maybe it's better to try to solve the suspend freezes.

If you wish to read, this is another topic about the same question: https://ask.fedoraproject.org/question/28092/fedora-19-disable-ati-graphics-card/

cleitonlima gravatar imagecleitonlima ( 2013-07-27 14:05:12 -0500 )edit

Cleitonlima:

I know it's been a while since you made this post, but it has been extremely helpful to me today. Ubuntu 14.04 simply would not boot from the install DVD on this Samsung 6GB AMD/Radeon laptop I have here in front of me (It isn't mine; it belongs to someone who has had problems with Windows malware more than once, in spite of taking security precautions.

Anyway, it just wouldn't boot; the opensource radeon drivers choked and instead of a desktop I got graphical garbage and a locked system.

Adding your parameters to the kernel boot command when booting from the DVD meant it suddenly worked. :)

If I could vote you up, I would. However, thanks. :)

dannyboy7796 gravatar imagedannyboy7796 ( 2015-03-25 06:41:56 -0500 )edit

Question Tools

Stats

Asked: 2013-07-26 09:32:55 -0500

Seen: 14,026 times

Last updated: Jul 27 '13