Ask Your Question

Problems with letter "ç" in US International Keyboard (Fedora 19)

asked 2013-07-16 18:26:53 -0500

Paulo Castro gravatar image

I'm having problems to reach the ç letter in my keyboard. I am using the "English US International with dead keys" layout in my keyboard and, different from other distros behavior (and Windows), when I type (' + c) I get ć (not ç as expected)

How can I fix this?

Also, this is Fedora's problem or GNOME's? Where should I report a bug?

edit retag flag offensive close merge delete


@paulocastro there goes a shot that worked for me bellow!

Andre Ferreira gravatar imageAndre Ferreira ( 2013-09-09 13:10:58 -0500 )edit

2 Answers

Sort by » oldest newest most voted

answered 2013-08-14 13:07:06 -0500

Andre Ferreira gravatar image

updated 2013-09-04 21:39:22 -0500

Finally after looking in many sources and really fight to find. This is the answer. What made it work for me.

Portuguese cedilla ç in english international keyboard layout!

Português cedilha ç no layout de teclado inglês internacional!

Fedora 19 x64

For Gnome GTK

  • Install gtk2-immodules - input methods (weird that is not installed by default):

    sudo yum install gtk2-immodules

    in my machine is gtk2-immodules.x86_64 0:2.24.19-3.fc19

  • Modify /etc/gtk-2.0/x86_64-redhat-linux-gnu/gtk.immodules the line

    "cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa"

    to (adding the cedilla input to en)

    "cedilla" "Cedilla" "gtk20" "/usr/share/locale" "az:ca:co:fr:gv:oc:pt:sq:tr:wa:en"

  • Certify that you are using the keyboard layout:

    us English (US) English (US, international with dead keys)

  • Modify /etc/X11/xinit/xinput.d/none.conf just the GTK_IM_MODULE value:


    log-out and log-in again. :D


The xim composite rule for each locale are stored in /usr/share/X11/locale/ Select desired locale, backup and change as desired.

  • Change your locale xim compose rule (mine en_US.UTF-8). Modify /usr/share/X11/locale/en_US.UTF-8/Compose following lines:

    <dead_acute><C> : "Ć" U0106 # LATIN CAPITAL LETTER C WITH ACUTE


    <dead_acute> <C> : "Ç" Ccedilla # LATIN CAPITAL LETTER C WITH CEDILLA


    <dead_acute> <c> : "ć" U0107 # LATIN SMALL LETTER C WITH ACUTE


    <dead_acute> <c> : "ç" ccedilla # LATIN SMALL LETTER C WITH CEDILLA

  • Modify if necessary /etc/X11/xinit/xinput.d/none.conf just the QT_IM_MODULE value:


    log-out and log-in again. :D

edit flag offensive delete link more


Also seams to be a bug but has not being updated to 19 Fedora

Andre Ferreira gravatar imageAndre Ferreira ( 2013-09-04 21:38:55 -0500 )edit

answered 2013-07-16 21:12:49 -0500

yanglifu90 gravatar image

updated 2013-08-14 14:18:17 -0500

You should use Alt Gr + , to produce ç with English (US, international with dead keys) keyboard layout, I guess things has changed now, when did you use Ubuntu or Windows? It is natural that ' - c will produce ć since on the layout the key ' is shown as acute accent ( ´ ).

See the layout here:

and see Example 2 on that page

edit flag offensive delete link more


This is why I'm using the us INTERNATIONAL layout. This layout makes possible the use of characters like ć and ç in a traditional US keyboard. The layout I'm using is OK in other distros (Ubuntu, Mint, etc.) but not on Fedora. =s

Paulo Castro gravatar imagePaulo Castro ( 2013-07-17 20:23:53 -0500 )edit

Go to Setting - Region & Language - Input Source - Add French French and press Super Key + Space to change to French.

yanglifu90 gravatar imageyanglifu90 ( 2013-07-19 01:55:23 -0500 )edit

In Windows it have always been '+c = ç, and there are typing productivity reasons for that, unless a weird key combinations.

lucianomx gravatar imagelucianomx ( 2018-03-23 12:01:04 -0500 )edit

Question Tools

1 follower


Asked: 2013-07-16 18:26:53 -0500

Seen: 10,396 times

Last updated: Sep 04 '13