Ask Your Question
0

Firefox don't display text anymore

asked 2013-07-15 13:20:34 -0500

Thomas gravatar image

updated 2013-07-17 08:24:29 -0500

FranciscoD_ gravatar image

Since a few days Firefox does not longer display any text (see screenshot).

When lanching Firefox from a terminal, I get this message :

(process:9208): GLib-CRITICAL **: g_slice_set_config: assertion `sys_page_size == 0' failed
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

followed by a bunch of those (the font and text parameters may varry) :

(firefox:9208): Pango-WARNING **: shaping failure, expect ugly output. shape-engine='BasicEngineFc', font='Liberation Sans 14.6669921875', text=' '

Note : I'm running KDE.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
0

answered 2013-07-16 23:26:56 -0500

cleitonlima gravatar image

Did you installed any fonts downloaded from internet in your system? I've found the same issue in Ubuntu's forum and that was the problem. After the user removed the fonts, Firefox worked normal again.

askubuntu.com/questions/172263/firefox6252-pango-warning-shaping-failure-expect-ugly-output-shape-eng

edit flag offensive delete link more

Comments

I searched the past yum transactions for font-related operation and found out that I had removed the liberation family (for some reason I don't remember...). Thank for the pointer.

Thomas gravatar imageThomas ( 2013-07-17 11:44:37 -0500 )edit

Question Tools

Stats

Asked: 2013-07-15 13:20:34 -0500

Seen: 351 times

Last updated: Jul 17 '13