Ask Your Question
0

How to setup bios to boot from fedora efi partition

asked 2013-07-12 13:29:37 -0500

hynner gravatar image

updated 2013-07-12 15:38:51 -0500

Hello, I´ve just installed fedora 19 on my HP ProBook 4540s, which comes with windows 8 preinstalled. I followed www.ambitious-vision.net/en/fedora-18-and-windows-8-uefi-how-to/ to install fedora and setup dual-boot with windows 8.

However the only way to get my computer to boot fedora is to manually select to boot from efi file and then choose the proper file. I want it to boot grub by default and there I can choose to boot windows. The only option I have right now is to create a custom boot, where I have to specify path to efi file I want to be booted, but I have no idea how such path should look like.

So could explain to me how such path looks like or how to achieve this some other and better way?

I tried unsetting boot flag from windows EFI partition and setting it on fedora´s one, but it didn´t help.

edit retag flag offensive close merge delete

Comments

randomuser gravatar imagerandomuser ( 2013-07-12 15:23:19 -0500 )edit

Well I have fedora´s EFI partition at the 1st place in efibootmgr, but it´s still booting from windows partition

hynner gravatar imagehynner ( 2013-07-12 15:31:14 -0500 )edit

Please edit your question to add the output of efibootmgr in a code block.

randomuser gravatar imagerandomuser ( 2013-07-12 15:40:28 -0500 )edit

Okay, I actually skimmed through your link, and I see where you went wrong. The EFI partition is a shared one, you don't create separate EFI partitions for Windows and Fedora.

randomuser gravatar imagerandomuser ( 2013-07-12 15:42:30 -0500 )edit

okay, and now tell me how to repair it ;-) BTW: I used efibootmgr and by accident I used -n parameter instead of -o and unlike -o it works :-) Any idea why it works with -n and not with -o?

hynner gravatar imagehynner ( 2013-07-12 23:29:05 -0500 )edit

1 Answer

Sort by » oldest newest most voted
0

answered 2013-07-13 07:33:35 -0500

hynner gravatar image

Ok, I managed to get it working by myself so here is what I did. I still have 2 EFI partitions. So I manually instaled rEFInd on Microsoft´s partition (using windows - bcdedit command didn´t make a difference though), set boot flag on it and add following path as my custom boot option: \EFI\refind\refind_x64.efi and ofc adjusted the boot order so that custom boot is on the first place.

And that´s it. It works like a charm now.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-07-12 13:29:37 -0500

Seen: 3,212 times

Last updated: Jul 13 '13