Ask Your Question
0

Recovering encrypted boot disk with bad fstab

asked 2013-07-06 16:19:06 -0500

MikeYPK gravatar image

updated 2014-09-28 23:52:38 -0500

mether gravatar image

I am hoping some expert out there can help. Need help with

  • fixing mounting the encrypted boot volume and fixing my fstab, so I can boot again.

  • figuring out how to setup a sane automount strategy for my encrypted backup volume.

Details: I set up an encrypted drive when installing fedora 19 with the live USB key. That worked well, until I decided to create an encrypted LUKS volume for backup.

I added an fstab entry with options "noauto, x-automount", since a regular fstab wouldn't work unless the usb drive is plugged in. And now

  • boot up fails, it would get stuck with messages in the console with 3 "a start job is running ..." for the backup drive.

  • I never saw GUI prompt for the drive passphrase like I did before I trued to set up an automount. I saw a prompt in the console for the passphrase, but typing in my passphrase there doesn't seem to help.

  • Unplugging the drive would cause 2 of the 3 jobs to realize the drive is not there and timeout, but I am still left with "A start job is running for Monitoring of LVM2 mirrors, snapshots etc." and it seems hopelessly stuck.

  • I wanted to boot into emergency mode, but the Grub2 setup seems different than the description on the web, and I can't get that to work.

  • I tried booting to the LiveUSB, but there I could not mount the encrypted boot volume. cryptsetup luksOpen would not recognize the encrypted boot volume (but it would the backup partition I created by hand.

Any help or advice would be much appreciated.

edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted
1

answered 2013-07-06 20:36:38 -0500

MikeYPK gravatar image

Turns out this is user error on my part.

I had a typo in the my fstab file, where I put down /dev/mapper/xxx as both the device and the mount point, which was the fundamental reason why the boot failed.

FYI, using defaults,noauto,x-systemd.automount worked well. I was able to boot with and without the USB drive connected.

And to fix the boot disk, I needed to do sudo cryptsetup luksOpen /dev/sdxx mntpoint

This put the encrypted volume at /dev/mapper/mntpoint, and also made the logical volumes available under /dev/mapper/

mount /dev/mapper/logical_volume_name /mnt Then allowed me to access and fix the fstab file

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-07-06 16:19:06 -0500

Seen: 678 times

Last updated: Jul 06 '13