Ask Your Question
0

problem to access net services in Fedora 19

asked 2013-07-05 16:31:01 -0500

jcezanna56 gravatar image

updated 2013-07-06 02:14:35 -0500

Hi, At the beginning : I had no problem in fedora 18 accessing my shares from mac os x 10.8.4 ( up to date) our windows 7 (using net use...). I reinstall my smb.conf add my usual user with smbpasswd and disabled selinux and firewall.

But I can't access my share. If I tried to mount -t smbfs //serveur ... I get server connection failed: Operation timed out. with winddows 7, I get a net path not found (translated from french).

I search on the net but didn't find any solution. Did you get the same problem ? I will apreciate any advice or idea. Thank you

edit : It seems I have the same problem for any service. I can access to http service in local but not from my macbook. The same for ftp. I really don't understand as I disabled the selinux !!! And when I use setsebool for instance, it returns me an error : "selunix is disabled". ... ?

edit: I tried with permissive in /etc/selinux/config and playing with setsebool -P xxx for any value I found in man apache_selinux and others. reboot. But no more success. Why I can't access my fedora 19 from my local net ?

edit retag flag offensive close merge delete

Comments

Disabling SELinux does not automatically cause your samba shares to be properly configured You can safely turn it back on; man samba_selinux is easy to understand and tells you everything you need to know. Add the relevant portions of your smb.conf for review, please.

randomuser gravatar imagerandomuser ( 2013-07-07 11:28:46 -0500 )edit

Disabling SELinux does not cause your firewall to automatically be defined according to your desire. You can safely turn your firewall back on, if you in fact succeeded in disabling it at all. firewall-cmd --permanent --add-service samba will allow samba traffic, and a very similar command will do the same for http. Add the output of firewall-cmd --list-services to your question for review, please.

randomuser gravatar imagerandomuser ( 2013-07-07 11:33:56 -0500 )edit

1 Answer

Sort by ยป oldest newest most voted
-1

answered 2013-07-08 02:57:47 -0500

jcezanna56 gravatar image

updated 2013-07-09 01:44:23 -0500

The problem was that there are 2 firewalls ! 1) iptable 2) firewall I didn't disable the one named "firewall". Once done, everything, id OK Thank you to every one who helps

I can't set the discussion to "solved" as I have not the number of points needed to, as said an error message --> stupid !

edit flag offensive delete link more

Comments

You aren't expected to change the title to include 'solved' - there's a check box where you can mark the answer that worked for you.

randomuser gravatar imagerandomuser ( 2013-07-11 01:48:47 -0500 )edit

Question Tools

Stats

Asked: 2013-07-05 16:31:01 -0500

Seen: 3,124 times

Last updated: Jul 09 '13