Ask Your Question
0

How to change keymap in virtual consoles?

asked 2013-07-04 18:09:58 -0500

faustus gravatar image

updated 2014-09-28 21:32:33 -0500

mether gravatar image

I use a dvorak keyboard layout in Fedora 19, and it works just fine on the X11 desktop. However, if I try to switch to a virtual console (e.g. with ctl-alt-F2), the layout is qwerty.

I have tried using localectl to change the layout. It reports the following:

System Locale: LANG=en_US.UTF-8
    VC Keymap: dvorak
   X11 Layout: us
    X11 Model: pc105
  X11 Variant: dvorak

...which would seem to indicate the Virtual Console (VC) Keymap is "dvorak" but it is a lie; when I switch to the VC it uses qwerty.

localectl populates the /etc/vconsole.conf file, which contains "KEYMAP=dvorak" as expected. I have also tried "us-dvorak" to no effect. How does one change the console keymap in Fedora?

edit retag flag offensive close merge delete

Comments

If you're running localectl as root, and the settings don't apply, it sounds like a bug.

randomuser gravatar imagerandomuser ( 2013-07-05 00:22:09 -0500 )edit

2 Answers

Sort by ยป oldest newest most voted
1

answered 2013-07-06 13:27:00 -0500

faustus gravatar image

It may have been a bug indeed, but it seems to have been corrected by the recent kernel update I installed (3.9.9-301.fc19). Selected keymap is now honored in virtual consoles. Thanks for your response.

edit flag offensive delete link more
0

answered 2013-08-27 05:03:36 -0500

Marcos Terra gravatar image

updated 2013-08-27 05:15:13 -0500

i confirm the bug

kernel (3.10.9-200.fc19) minimal install (only console)

System Locale: LANG=pt_BR.UTF-8
VC Keymap: br-abnt2
X11 Layout: br
X11 Model: abnt2
X11 Options: terminate:ctrl_alt_bksp

custom map cause the keyboard has "/" and "?" on keys "q" and "w"

not work running

# localectl set-keymap br-abnt2

work running

# localectl set-keymap br

localectl show this and map works

System Locale: LANG=pt_BR.UTF-8
VC Keymap: br
X11 Layout: br
X11 Model: abnt2
X11 Options: terminate:ctrl_alt_bksp

if run again

# localectl set-keymap br-abnt2

localectl show this and map still works

System Locale: LANG=pt_BR.UTF-8
VC Keymap: br-abnt2
X11 Layout: br
X11 Model: abnt2
X11 Options: terminate:ctrl_alt_bksp

conf files are setting ok

/etc/vconsole.conf is ok
KEYMAP=br-abnt2

/etc/default/grub is ok 
/boot/grub/grub.cfg is ok

running loadkeys poiting to map works too

~# loadkeys ../lib/kbd/keymaps/i386/qwerty/br-abnt2.map.gz
edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-07-04 18:09:58 -0500

Seen: 3,174 times

Last updated: Aug 27 '13