Ask Your Question

Permission denied (publickey) to

asked 2013-07-04 12:19:18 -0500

fergatron gravatar image

I'm having a problem logging into via SSH. I haven't done so in a long time so yesterday I updated my FAS information and added a new public key. I'm unable to decipher what the problem is based on the printout below.

I do have a fergatron and a file in my ~/.ssh directory.

$ ssh -vi ~/.ssh/fergatron
OpenSSH_6.2p2, OpenSSL 1.0.1e-fips 11 Feb 2013
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 50: Applying options for *
debug1: Connecting to [] port 22.
debug1: Connection established.
debug1: identity file .ssh/fergatron type 1
debug1: identity file .ssh/fergatron-cert type -1
debug1: Enabling compatibility mode for protocol 2.0
debug1: Local version string SSH-2.0-OpenSSH_6.2
debug1: Remote protocol version 2.0, remote software version OpenSSH_5.3
debug1: match: OpenSSH_5.3 pat OpenSSH_5*
debug1: SSH2_MSG_KEXINIT sent
debug1: SSH2_MSG_KEXINIT received
debug1: kex: server->client aes128-ctr hmac-md5 none
debug1: kex: client->server aes128-ctr hmac-md5 none
debug1: SSH2_MSG_KEX_DH_GEX_REQUEST(1024<1024<8192) sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_GROUP
debug1: SSH2_MSG_KEX_DH_GEX_INIT sent
debug1: expecting SSH2_MSG_KEX_DH_GEX_REPLY
debug1: Server host key: RSA 07:d4:02:db:9f:70:d5:2d:7f:1b:6a:df:83:73:95:1d
debug1: Host '' is known and matches the RSA host key.
debug1: Found key in /home/marc/.ssh/known_hosts:10
debug1: ssh_rsa_verify: signature correct
debug1: SSH2_MSG_NEWKEYS sent
debug1: expecting SSH2_MSG_NEWKEYS
debug1: SSH2_MSG_NEWKEYS received
debug1: Roaming not allowed by server
debug1: SSH2_MSG_SERVICE_ACCEPT received
debug1: Authentications that can continue: publickey
debug1: Next authentication method: publickey
debug1: Offering RSA public key: .ssh/fergatron
debug1: Authentications that can continue: publickey
debug1: No more authentication methods to try.
Permission denied (publickey).
edit retag flag offensive close merge delete

1 Answer

Sort by ยป oldest newest most voted

answered 2013-07-04 23:11:11 -0500

FranciscoD_ gravatar image

The public key takes some time to sync. Please try again in a while and it should work. If you have further issues, please contact the infrastructure team on #fedora-admin on Freenode over IRC or file a ticket at their track instance.

edit flag offensive delete link more


So; this wasn't the exact answer to my problem, but it lead me in the right direction. Talking to the guys at #fedora-admin they informed me that I needed to be a member of at least one "non-cla" group.

fergatron gravatar imagefergatron ( 2013-07-10 21:06:41 -0500 )edit

Question Tools

1 follower


Asked: 2013-07-04 12:19:18 -0500

Seen: 760 times

Last updated: Jul 04 '13