Ask Your Question
2

Can't use kdm instead of gdm

asked 2013-06-20 15:42:02 -0500

Rafael Adel gravatar image

updated 2013-08-28 07:43:36 -0500

ryanlerch gravatar image

I'm trying to use kdm instead of gdm.

I've created /etc/sysconfig/desktop, and added these lines:

#!/bin/bash
DESKTOP="KDE"
DISPLAYMANAGER="KDE"

And restarted. But still, gdm is set as default display manager. This is the file permissions :

-rw-r--r--. 1 root root 47 Jun 20 22:15 /etc/sysconfig/desktop

Any help would be appreciated, thanks.

edit retag flag offensive close merge delete

Comments

@skytux But is doing this using /etc/sysconfig/desktop is discarded now or what ? I really want to understand the reason why this didn't work.

Rafael Adel gravatar imageRafael Adel ( 2013-06-21 08:11:08 -0500 )edit
2

You are right. Switching display managers is no longer done by editing the file /etc/sysconfig/desktop. (http://docs.fedoraproject.org/en-US/Fedora/18/html/Release_Notes/sect-Release_Notes-Changes_for_Desktop.html)

skytux gravatar imageskytux ( 2013-06-21 09:23:27 -0500 )edit

@skytux Very helpful. Thanks a lot.

Rafael Adel gravatar imageRafael Adel ( 2013-06-21 12:28:20 -0500 )edit
1

@Rafael Adel You are very welcome! :)

skytux gravatar imageskytux ( 2013-06-21 12:55:31 -0500 )edit

4 Answers

Sort by » oldest newest most voted
2

answered 2013-06-20 17:54:28 -0500

skytux gravatar image

Disable gdm and enable kdm:

$ sudo systemctl disable gdm

$ sudo systemctl enable kdm

When restarting, you should be able to log in using kdm.

HTH,

Germán.

edit flag offensive delete link more

Comments

Very nice, did the exact job that randomuser told me to do. Thanks.

Rafael Adel gravatar imageRafael Adel ( 2013-06-20 19:24:25 -0500 )edit
1

But you don't need to do it manually, that is why you have the commands I listed above: systemctl disable gdm and systemctl enable kdm. In that way, the symlink is set automatically. Please, read the documentation of systemd.

skytux gravatar imageskytux ( 2013-06-20 20:05:17 -0500 )edit

I was about to. Thanks a lot.

Rafael Adel gravatar imageRafael Adel ( 2013-06-20 20:06:39 -0500 )edit
1

answered 2013-06-20 17:53:56 -0500

/etc/systemd/system/display-manager.service is a symlink.

GDM and KDM come with service files. Point the above symlink at the service file included with your desired display manager.

edit flag offensive delete link more

Comments

1

Amazing now i understand how this works. But does that means that the /etc/sysconfig/desktop method is discarded ?

Rafael Adel gravatar imageRafael Adel ( 2013-06-20 19:23:50 -0500 )edit
0

answered 2015-02-09 10:19:50 -0500

fche2 gravatar image

See system-switch-displaymanager, a program that manipulates the /etc/systemd/system/display-manager.service symlink.

edit flag offensive delete link more
0

answered 2013-06-20 22:27:00 -0500

skytux gravatar image

I used to do this before Systemd, but don't remember to have a shebang in the file. Nevertheless, as I said in my answer, all you need is to use systemctl from now on.

edit flag offensive delete link more

Question Tools

Stats

Asked: 2013-06-20 15:42:02 -0500

Seen: 8,459 times

Last updated: Feb 09 '15