Ask Your Question
1

environment group

asked 2013-06-17 11:59:14 -0500

gat gravatar image

updated 2013-06-18 22:37:09 -0500

FranciscoD_ gravatar image

I tried to install "GNOME Desktop" on F19. As a result every "yum update" shows me the following: "Warning: Environment Group gnome-desktop-environment does not exist."

I have tried to remove this warning with "yum clean all". That didn't do it. I have found bugs rhbz#920055 and rhbz#864943 to be seemingly related.

$ grep -r -H "gnome-desktop-environment" /var
/var/cache/yum/x86_64/19/updates-testing/gen/comps.xml:    <id>gnome-desktop-environment</id>
/var/cache/yum/x86_64/19/updates-testing/gen/comps.xml:    <id>gnome-desktop-environment</id>
/var/cache/yum/x86_64/19/fedora/gen/comps.xml:    <id>gnome-desktop-environment</id>
/var/cache/yum/x86_64/19/fedora/gen/comps.xml:    <id>gnome-desktop-environment</id>
Binary file /var/cache/PackageKit/groups.sqlite matches
Binary file /var/lib/rpm/Packages matches
Binary file /var/lib/rpm/Basenames matches
/var/lib/yum/groups/environment:gnome-desktop-environment
Binary file /var/lib/mlocate/mlocate.db matches

Some of these are binaries and - mostly - uneditable. I tried editing /var/lib/yum/groups/environment to read gnome-desktop-environment as "false" in lieu of "16". That resulted in failed execution of yum. I could try using dnf provided that someone thinks that it will lead to a solution.

How do I remove this warning?

edit retag flag offensive close merge delete

Comments

I don't know how it will bear on your problem, but I've been using dnf regularly for a while now and find it to be quite a bit faster than yum.

randomuser gravatar imagerandomuser ( 2013-06-18 01:05:55 -0500 )edit

I have, also, been using DNF for quite a while. YUM is still much more extensive.

gat gravatar imagegat ( 2013-09-25 23:11:19 -0500 )edit

3 Answers

Sort by ยป oldest newest most voted
3

answered 2013-09-25 23:10:33 -0500

gat gravatar image

To remove the warning issue the following command.' $ su -c "yum group mark remove gnome-desktop-environment"

If you have a similar warning, then replace "gnome-desktop-environment" with the name of the other "environment group". Refer to http://fossdev.blogspot.com/2013/08/yum-on-fedora-19-new-groups-as-objects.html.

edit flag offensive delete link more
0

answered 2013-09-26 10:24:59 -0500

sea gravatar image

updated 2013-09-28 02:32:06 -0500

yum grouplist

Shows me this:

Loaded plugins: langpacks
Available environment groups:
GNOME Desktop
...

According to previous experiences with groups, i'd suggest to try either one of the two below as root:

yum install @gnome
yum groupinstall "GNOME Desktop"

Hope this helps

edit flag offensive delete link more

Comments

2

yum grouplist -v shows the group short names, to be used like yum install @gnome-desktop-environment

randomuser gravatar imagerandomuser ( 2013-09-28 02:33:07 -0500 )edit

yum groupinstall gnome

Works just 'fine' on my system.

This works for: gnome, lxde, xfce, only kde requires -desktop

sea gravatar imagesea ( 2013-10-03 17:29:44 -0500 )edit
-1

answered 2013-08-11 14:26:44 -0500

I got this error: [root@A00138 ~]# yum update Loaded plugins: changelog, dellsysid, langpacks, refresh-packagekit Warning: Environment Group gnome-desktop-environment does not exist.

The system would not update

I ran 'yum clean all' and the problem went away.

edit flag offensive delete link more

Comments

I tried this several times without avail.

gat gravatar imagegat ( 2013-09-25 23:12:07 -0500 )edit

Question Tools

1 follower

Stats

Asked: 2013-06-17 11:59:14 -0500

Seen: 4,061 times

Last updated: Sep 28 '13